35

I'm using Gnome Shell (although I'm not sure whether the "Printers" app is part of that or just part of Gnome).

I go to "Printers" from the overview, click the + button on the bottom left, choose network and then see a message "FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall.".

It's not auto detected anything. There's an Address box and a Search by Address tickbox, but neither seem to do anything. I'm frustrated because I know all the details of the printer, but have nowhere to put them in. Automation is supposed to make things easier, no?

For example I know the printer is at lpd://10.67.5.3/lp1 but I can't put this in anywhere.

Is there a GUI that works, or have I misunderstood how to use it?

  • 4
    Wow the port 631 localhost works in Debian Linux as well! After dealing with the native printer interface (still mystified trying to adjust double sided printing or to see the IP address in plain English) the step-by-step interface of the CUPS internal web site is just what I needed. I now have a launcher on my desktop for "Printers." – user156781 May 8 '13 at 13:19
  • 2
    The native CUPS interface will work with any system that uses CUPS and hasn't disabled it. So that's Debian, Mint, millions of other linux flavours, and Mac OSX etc. – artfulrobot May 8 '13 at 14:24
52

The Gnome Printer interface still has quite a few bugs (like the one you mentioned). To use the Printer interface that comes with Ubuntu, press Alt F2, and type in system-config-printer.

| improve this answer | |
  • 11
    It's 2017 now. Gnome Printer is still buggy as hell. – Oki Erie Rinaldi Jan 9 '17 at 6:48
  • 1
    This works in CentOS 7 also. And yes, Gnome Printer is terrible – reas0n Mar 7 '17 at 22:33
  • This does not work, as @OkiErieRinaldi said. It still gets stuck at "installing openprinting-gutenprint" and thus is utterly useless. – Jan M. May 21 '17 at 16:58
  • I had to sudo apt install system-config-printer on Ubuntu Gnome 17.04 – joelittlejohn Jun 26 '17 at 14:04
  • 2
    Hi it's 2019 and it is still a piece of crap. – Jan M. Feb 18 '19 at 12:58
33

Ditch gnome's GUI and revert to the good ol' CUPS interface at http://localhost:631

Click Add Printer and follow the instructions on screen.

| improve this answer | |
  • 4
    wow never knew about that. this is totes the purest way to manage printers. – Robin Winslow May 21 '13 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.