I am using 12.04 LTS dual boot, and I can't use the bluetooth service in Ubuntu. It works fine with Windows 7. In Ubuntu I can turn on the bluetooth from the titlebar but when I switch on the visibility it automatically switches back (I'm using GNOME 3 environment).

All this happened after the 1st update (worked fine before then).


7 Answers 7


Found an easier solution than reseting BIOS!

sudo hciconfig hci0 reset

bluetooth was enabled on ubuntu 12.04.

I could do file transfer between Nexus7 and my laptop. but nexus7 stopped playing music and laptop started playing music!

  • 1
    Doesnt help...!
    – asheeshr
    Aug 12, 2013 at 14:46
  • 2
    You might need to unblock the device first: Check sudo rfkill list to see if it's blocked, then unblock it: sudo rfkill unblock <id>. Now if you do sudo rfkill list again you will see the new device named hci0. You can now reset it using the above command. I needed to restart afterwards to make it work again.
    – jmiserez
    Nov 3, 2013 at 23:47
  • I had trouble when I tried a dedicated bluetooth (Sennheiser BTD 500) audio dongle instead of my regular one and must have messed something up on my desktop. I couldn't pair my Wacom and headset again, even after reboot and rfkill. This one worked!
    – LiveWireBT
    Jan 23, 2014 at 15:42
  • Tried but: Can't get device info: No such device
    – Natim
    Mar 21, 2014 at 16:15
  • 1
    Works on Kubuntu 14.04
    – Manck
    Aug 8, 2014 at 19:28

I've got the same issue, and it turned out that Bluetooth was turned off in windows... If you use both windows and ubuntu on the same machine, try this command:

rfkill list all

If it says that Bluetooth is soft blocked then try to enable it on windows and then check again if it works on ubuntu also.

  • 1
    sudo rfkill unblock <id> to unblock the device.
    – jmiserez
    Nov 3, 2013 at 23:45
  • 1
    I don't see any bluetooth in the list: 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no
    – Rasoul
    Jan 14, 2014 at 18:05
  • @Rasoul the same for me; did you managed to make it work? if so, how? please
    – Jo Rijo
    Apr 15, 2014 at 19:42

I got this problem since I installed 12.04. I have tried many ways to install bluetooth, then changing if my bluetooth is soft blocked or not, then reinstall my bluetooth software on Ubuntu I had done it all.

But I found the BEST WAY to enable bluetooth with:

  1. Restart your Ubuntu

  2. Go to BIOS program (through Del or F2 - its optional based on your computer)

  3. Set the BIOS to 'reset to factory setting' usually using F9 or else its based on your type of BIOS

  4. Startup, then go to your bluetooth you will found that your bluetooth wont disabled again.

Good luck.


Just had this problem (on 12.10), solution I found: kill blueman-applet and start it again. Run blueman-applet & from a terminal to start it.


Check your bluetooth device ,see if the bluetooth is switched off by hardware switch. If that is the case, turn the bluetooth hardware switch on.


Setting to Factory Defaults helped me instantly with the Wireless and Bluetooth. They were shutdown in Ubuntu 13.04 for me.

  • Welcome to Ask Ubuntu! Setting what to factory defaults exactly? You posted this as an answer to the original question, but perhaps you meant to comment to an other answer?
    – gertvdijk
    Jun 23, 2013 at 10:09
sudo apt-get install linux-firmware

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.