6

All my menus are highlighted like in the attached image.

http://i.imgur.com/GVoIh.png

I asked around and someone told me my gtk theme might be broken. However, I have no clue how to fix it. This occurs on my system menus, DE changer in the login menu, and most other programs.

  • Do you have the Gnome 3 (both, testing) PPAs activated? if you do, an update might just have happened, and yes the GTK Theme needs to be updated to reflect the changes – Uri Herrera Jun 20 '12 at 7:18
  • Both PPAs were activated. I'm not sure how to update a GTK theme though. – Anonymous Jun 20 '12 at 17:49
  • Yeah, happened to me too you''l have to use the gnome packages from Ubuntu or wait for the author to update the theme. – Uri Herrera Jun 20 '12 at 17:50
2

It's problem with unity-settings-daemon / gnome-settings-daemon. You can report a bug here.

  • On Ubuntu 14.04 and newer following command should fix problem (run it from a Terminal):

    sudo killall -9 unity-settings-daemon && unity-settings-daemon & disown
    
  • On Ubuntu older than 14.04 tou can try (run it from a Terminal):

    sudo killall -9 gnome-settings-daemon && gnome-settings-daemon & disown
    
  • Thanks a lot, I was struggling with this for a month it fixed it. – Natim Sep 16 '16 at 18:56
1

As I commented, an update brakes compatibility with Themes.

So you'll have to remove the Gnome 3 Team PPA and the Ricotz testing PPA then downgrade the packages to the Ubuntu version.

Install ppa -purge to make this easier.

0

In my case, for Unity I fixed this problem by deleting ~/.config/gtk-3.0 that I had left over from some earlier tweaking when still using 12.04.

With Xfce, I had this problem when using Settings / Appearance / ambiance-xfce-lxde theme that I got from http://www.ravefinity.com/p/ambiance-radiance-for-xfce-lxde.html

For Xfce, I fixed this by making a new theme with everything else from Ambiance, but the gtk-2.0 folder from ambiance-xfce-lxde:

cd /usr/share/themes
sudo cp -r Ambiance MyAmbiance
sudo cp -r ambiance-xfce-lxde/gtk-2.0/ MyAmbiance/

and then selecting MyAmbiance from Settings / Appearance.

Edit: Now on xubuntu-desktop on Ubuntu 16.10, and this trick still helps to fix some appearance issues when using the above theme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.