I'm using dolphin under gnome 3 and when I select a file, the name disappears. I tried looking at my kde settings and looking under colors and nothing seems out of the ordinary, and I don't know if that is where dolphin is getting its colors from since I'm using gnome 3. I'm using Ambiance for a color theme, so I looked in /usr/share/themes/Ambiance/gtk-3.0/gtk.css and saw base color is white and so is selected fg color. So I changed them to black and got nothing. It appears that dolphin is getting its color information from gnome 3 since when changing from Ambiance to Adwaita the colors change in dolphin.

So how do I get the filename not to disappear when I select a file in dolphin and hover over it?


6 Answers 6


With root privileges, please change in the following file:






I figured this out in a long search for the right configuration file.
I also tried changing it in .local/share/... but it did not work that way for me.

  • Note that this affects selected text color everywhere, not just in Dolphin. It looks OK though so for me it's not a problem.
    – Lapis
    Jun 12, 2013 at 12:48
  • 1
    Thanks for this answer. I changed bg to #80f080 and fg to #a00000, and it works fine for me.
    – tpg
    Jul 7, 2013 at 9:09
  • I'm still having issues with this despite changing any of these values the white still remains while my mouse is hovered over the text Jan 8, 2016 at 11:27
  • Note that if your active theme is not Ambiance, you need to replace it in the path with yours.
    – Lapis
    Feb 16, 2016 at 20:20

I have struggled with the various solutions posted for hours now and have finally gotten mine working. I am running KDE Plasma on Ubuntu and a file selected AND hovered over will disappear. First, you need to figure out what theme you are using (System Settings -> Appearance -> Application Style -> (and then Window Decorations or GTK .. not sure which, but both of mine were set to the same). In this example my theme is "theme_name". Find this theme file here:


Find the line that contains "selected_fg_color:". Change the six digits after the : to all zeros:


You will need to restart Dolphin after this change. This changes the text when you select and hover to black. If you are running a theme with a white background it still won't look perfect because the background will be white, and not look selected (but at least you can read it now). You can change the color of the background fill by adjusting "base_color" in the same file. However, this changes the base background color for the whole theme... so it will change other things too.

I think that some who have said this fix does not work for them may be editing the gtkrc file for the wrong theme.


In Ubuntu Studio I found that this problem can be solved by selecting a different Style in Windows Manager, e.g. from MurrinaDark to MurrinaBlue.


Apologies, that did not work after all. The following worked:

sudo gedit
goto   /usr/share/themes/Greybird/gtk-2.0/gtkrc
    change from:
gtk-color-scheme    = "bg_color:#CECECE\nselected_bg_color:#398ee7\nbase_color:#fcfcfc" # Background, base.
gtk-color-scheme    = "fg_color:#3C3C3C\nselected_fg_color:#000000\ntext_color:#212121" # Foreground, text. 
gtk-color-scheme    = "bg_color:#CECECE\nselected_bg_color:#ccff99\nbase_color:#fcfcfc" # Background, base.
gtk-color-scheme    = "fg_color:#3C3C3C\nselected_fg_color:#0000cc\ntext_color:#212121" # Foreground, text. 
  • I'm sorry, but none of this is working is there some other solution to this? uiuiui Jan 8, 2016 at 12:04

I had the same problem running dolphin in kde. I also had ubuntu-mate installed and apperantly it still set an environment key for qt apps to run gtk2 theme:


You can test for yourself on your system with:


This will use the styles set in ~/.config/kdeglobals which you can change with the settingsmanager of kde.

Other options are to use qt5ct but it is not in the official repos. See this post on webupd8


Go to the ~/.config/kdeglobals and add these lines

BackgroundNormal=94, 104, 109

the #s representing the RGB value of whatever color you choose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.