zramswap-enabler has put my package manage in an "inconsistent state."

I tried forcibly removing it with this commend:

dpkg --remove --force-remove-reinstreq

But it seems to freeze and doesn't complete operation.

I tried modifying my dpkg status file as recommended here, but that didn't work either. When I tried upgrading my other files, zramswap still showed up, and stopped it from completing.

Are there any other ways I can force remove this file, or will I have to reinstall Ubuntu?


I figured it out.

I killed dpkg from the background.

sudo killall -9 dpkg

Removed zram swap references from the dpkg status file.

sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.bkup
sudo gedit /var/lib/dpkg/status

Removed the zram sources from the package manager.

I used the gui.

Than ran this.

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.