7

When I try to importing photos from my external harddisk into Shotwell, after disconnecting the HDD the photos disappear immediately.

I saw that the photos had been imported into the database without being copied. Copying the whole file into the picture file is possible, but I would like to be able to keep the initial file order in my library (by filenames), not the one made by Shotwell (by date).

There was no problem copying photos from a dvd.

Is there any possibility to have the same file structure for all photos or is there a bug in Shotwell?

Thanks

1
  • 2
    Thanks to all, I found the solution! First I had to cancel all Fotos from separate Missing Files view which appeared in the sidebar. Thanks – user65764 Jun 20 '12 at 8:37
5

When you import a folder with pictures into Shotwell it gives you two options:

enter image description here

In the first case, Copy Photos, Shotwell will store a local copy of the pictures in your computer. Thus, if you import from a removable drive, you will always have a copy of them available.

In the second case, Import in Place, shotwell will only create links to the pictures, thus if you unplug a removable drive with the pictures they will not be available.

If you want to preserve your structure of folders for your pictures I recommend that you copy your pictures manually to your hard drive (Pictures folder is a good option). After that you can Import in Place from shotwell (does not make sense to have 2 local copies of your pictures) and you will have them available. Shotwell will still classify them by date (default), but then you can 'Tag' your pictures if you want to arrange them in a different order (e.g. 'my birthday').

1
  • 4
    As the OP points out in a comment above, the copying option does not work correctly (i.e. it does not copy) if the photos had been imported before and the files then moved, and it that case instead they need to be deleted from the "Missing Files" view before doing the import. Only after that it works as expected. – fuenfundachtzig Sep 7 '15 at 18:35
3

Thanks to all, I found the solution!

First I had to remove all Photos from a separate Missing Files view, which appeared in the sidebar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.