Before I mention anything further, DO NOT give me a response saying that terminal won't show password input. I'm AWARE of that.

I'm typing my user password in (not a capslock issue), and for some reason it still says 'Authentication Failure'.

Is there some other password (one I'm not aware of) I'm supposed to be using other than my user password? I've had this ubuntu before, on another hard drive and I didn't have this problem. (And it was the same ubuntu, ubuntu 12.04 LTS)

ai@AiNekoYokai:~$ groups
ai adm cdrom sudo dip plugdev lpadmin sambashare
ai@AiNekoYokai:~$ lsb_release -rd
Description:    Ubuntu 12.04 LTS
Release:    12.04
ai@AiNekoYokai:~$ pkexec cat /etc/sudoers
# This file MUST be edited with the 'visudo' command as root.
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
# See the man page for details on how to write a sudoers file.
Defaults    env_reset
Defaults    secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root    ALL=(ALL:ALL) ALL

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command
%sudo   ALL=(ALL:ALL) ALL

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d

I can log in with my password, but it's not accepted as valid for authentication <-- That is pretty much my issue. (Although, I haven't gone into recovery mode.)

I've ran:

ai@AiNekoYokai:~$ ls /etc/sudoers.d

And also reinstalled sudo with:

pkexec apt-get update
pkexec apt-get --purge --reinstall install sudo

pkexec usermod -a -G admin $USER <- Says admin does not exist

su $USER <- worked for me, however, my password still does not do much (in sense of not working for other things)

I changed my password with pkexec passwd $USER. I was able to change it no problem.

gksudo xclock was something I was able to get into, no problem. (Clock showed)

ai@AiNekoYokai:~$ gksudo xclock
  • 1
    I had same problem after I edited /etc/pam.d/common-sessions-noninteractive to stop cron logs in auth.log by adding some lines to it, the password worked again after I removed the added lines
    – razzak
    Jul 23, 2017 at 0:44

4 Answers 4


I had this problem when I was using a special keyboard layout (Bépo). The terminal was not recognizing the special characters. Maybe this is your problem too ?

How to change the keyboard-layout in the console, with special characters?

  • I appreciate you trying to help, but I don't have a special keyboard layout. But I do thank you very much for the effort! ^-^
    – Souta
    Jun 18, 2012 at 23:56
  • This did it for me (Lubuntu install) when I was using "English - English(US, international with dead keys)" and switched to "English - English (US)".
    – Blue Ice
    Aug 25, 2014 at 21:02

Run pkexec passwd $USER to change password. Then retry.

If it doesn't work, there are other troubleshooting things you can do (detailed in the question above).

  • 1
    Are you saying that pkexec passwd $USER worked for you? I'd gotten the sense that it did not, and that the problem was instead because of some typo you'd been making (something like using su instead of sudo, but not necessarily that). Jun 21, 2012 at 2:53
  • It was part of both. I kept typing something wrong (unsure what it was) but then on the last time I tried it, I managed to get it working. I honestly think it was mostly a password issue. I was using some special characters (not umlaut-special), and a friend of mine pointed out something to me with how my previous password started and how the terminal might have mistook said password. (That, or it was just some freaky glitch, but since it hasn't happened since password change, I'm calling user error on myself.)
    – Souta
    Jun 21, 2012 at 13:42

I had this problem today. My password was the same but when I entered it for sudo it no longer worked. I am slightly concerned that I have been hacked, but that would be difficult because two firewalls would have to be compromised, and no one in the household would know how to change a passwd but me, so I am assuming that is not the issue, but I changed both user and root passwds as a precaution. Still not sure as to cause.


  1. alt-ctrl-f2 moves to a console. This does not work in a terminal or via su
  2. Login as root You need to have root's password, which is not the same as sudo.
  3. Execute command passwd USERNAME with your user name substituting for 'USERNAME'
  4. Enter a new password and confirm. Logout.
  5. alt-ctrl-f7 brings you back to your desktop.
  6. close all open terminals
  7. Open a new terminal and test with sudo ls.

This worked for me anyway. I was locked out of my account for 8 minutes because of fails, but I think this reset that timer. Anyway you might need to wait a few minutes or type 'man passwdand look up how to unlock the user from thealt-ctrl-f2` root account.

This will work even if you are at a desktop manager login screen, and you cannot login to your DM, as the alt-ctl-f2 console does not depend on the GUI at all.

  • FYI most Ubuntu installations do not have a root user account as this is generally frowned upon. Instead users are give sudo permissions and using sudo allows root-like powers. Mar 14, 2021 at 23:34

Why dont you add (to be more explicit)

# User privilege specification
root    ALL=(ALL:ALL) ALL  
ai      ALL=(ALL:ALL) ALL

Not the answer you're looking for? Browse other questions tagged or ask your own question.