24

I've installed on my host ubuntu 10.04 in virtualbox guest operating system ubuntu 12.04. And mouse wheel doesn't scroll vertically the contents of a window. In host works normally. VirtualBox mouse indicator in the right bottom corner flashhes when I'm using mouse wheel.

  • 6
    Have you installed Guest additions? – Mitch Jun 18 '12 at 20:35
  • 1
    Installing the guest additions made the mouse wheel work (Guest OS was Mac OS X 10.8) – Wim Deblauwe Aug 31 '12 at 14:51
29

I also had this same problem, other distros in VirtualBox accepted mouse wheel scrolling without a problem.

My fix was in the "Machine" menu of the VirtualBox window in which Ubuntu was running, select "Disable Mouse Integration". Mouse wheel scrolling works after that.

I am using a wired mouse into a PS/2 port on the host.

| improve this answer | |
  • Worked for me thanx! – Zaptree Aug 23 '12 at 3:07
  • worked for me with wired usb mouse. thanks for the tip. – Victor Jan 5 '13 at 0:54
  • Note that mouse wheel scrolling should work with mouse integration. – Kyle Strand Feb 19 '16 at 23:25
  • 1
    This has since moved to the Input menu instead of Machine – ashes999 Mar 14 '16 at 13:45
12

You should update to the latest VirtualBox and extension pack, and reinstall vbox addition. Everething works fine after it, tested minute ago.

| improve this answer | |
  • 1
    This. That way, you don't have to disable mouse integration, which I find very handy. – levesque Jan 27 '13 at 19:30
  • This is the actual answer, since you don’t lose any functionality when you do this. – AeroCross Feb 28 '13 at 23:56
  • As long as the latest extension pack is fully compatible, yes. Otherwise disabling mouse integration is the only thing that works. Some oddity is preventing that at the moment. – Fiasco Labs Aug 2 '13 at 17:58
  • I updated VBox a couple of days ago and installed the extension pack and I have this problem. The "disable mouse integration" works. (VBox with ubuntu 12.04 running on mac 10.6) – Juh_ Oct 17 '13 at 13:19
6

In my case, (Lubuntu 13.04), while the Disable Mouse Integration hint works, I installed virtualbox-guest-x11. This enabled me to use the mouse wheel

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.