Cheers to you. I got a problem in making a Mobile-BroadBand connection in Ubuntu 11.04, using 'Huawei e303c' usb data-card. I'm using Tata Docomo 3G sim-card (India, circle: Maharastra).

My observations:

  1. I installed the device's driver 'Mobile-Partner For Linux'(which came up with the device). But it is not detecting my device.

  2. In Network Manager, Adding a Mobile-BroadBand connection is not able to detect the device (with or without the device's driver installed).

  3. I tried softwares like usb_modeswitch, gnomeppp, wvdial, sakis3G and followed their guidelines. These too didn't work.

  4. Without the driver, the system is able to identify the device (Mobile-Partner icon comes-up, that leads to driver setup files). But after installing the driver, nothing comes-up there.

  5. In all the above cases, when 'lsusb' cmd is fired, the prompt shows the connected data card (as 'DEVICE_ID:VENDOR_ID Huawei Technologies Ltd.,').

This is my problem. Give a solution to get my device connected.


  • I am also facing the same problem. Is there any help? – newuser Nov 13 '12 at 11:45
  • :) i tried many of the tips and tricks posted on various sites. Sometimes 'wvdial' worked. But when i upgraded to Ubuntu 12.04 everything went well. Just insert the device, the remaining will be taken care of by the OS (just follow the prompts). I think when it comes to Ubuntu-11.04/11.10 there are some OS/patch issues in detecting the wireless broad-band modem. – Umashankar Nov 18 '12 at 16:21

I encountered the same problem. Earlier the datacard was working fine with Ubuntu 12.04, without installing any software. But as soon as I installed the linux drivers which were bundled with the device, it stopped working.

After a lot of searching, and digging into the install script, I found a simple solution. Run the following commands in the terminal, to get Huawei E303c working again:

sudo apt-get remove usb-modeswitch usb-modeswitch-data
sudo apt-get install usb-modeswitch

These commands will reinstall usb-modeswitch. Actually, the whole problem arises because Huawei drivers modify the usb-modeswitch data files, reinstalling them will solve the issue.

| improve this answer | |
  • 1
    No this didn't work..Still for 'lsusb' cmd the modem (Huawei e303c) is showing up but not detected by network manager. Even attempts using 'Sakis3G' fails! – Umashankar Jul 9 '12 at 8:17
  • Thanks a ton!, this works like magic even on ubuntu 12.04 – Ankur Agarwal Oct 15 '13 at 18:33
  • I followed the 2 commands you told, then what to do? – Arup Rakshit May 6 '14 at 17:32
  • I did this back in 2012 with Ubuntu 12.04, don't know if it will work in more recent ubuntu distribution – Pankaj May 7 '14 at 9:21
  • @Pankaj sir, thanks a lot, just followed your instruction after wasting 6 hours and now works like charm!... i am using ubuntu x64 15.04 :) +1 – Mohammed Sufian Sep 21 '15 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.