7

I have an amazon micro instance which runs one or two things for me. The config is minimal, it mainly acts as a host for a java application and couchdb.

I tried to install curl today and got this message:

sudo apt-get install curl
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So I ran the command using sudo:

sudo dpkg --configure -a
Setting up openjdk-6-jre-headless (6b20-1.9.1-1ubuntu3) ...

and it's been hanging there for a looooooong time. Top reports that a java process is using just about all of my CPU. Any ideas what this problem is and how I can fix it? Any ideas on what caused the issue?

3

You're running into bug 634487.

The work arounds are:

  • use x86_64 instance type
  • stop instance, start as m1.small, dpkg --configure -a, stop, start as t1.micro
| improve this answer | |
  • I'm not really sure how to start the instance 'as' an m1.small. Can you do that with the web console? – Pieter Breed Nov 29 '10 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.