0

I've installed eclipse but it won't launch. I tried launching from the app launcher and with the terminal and I keep getting this error:

An error has occurred. See the log file /home/kreshendo/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/1339994725811.log.

I can post the log information if you need it.

3
  • 4
    Include the log file in your post. By that the problem will be more clear.
    – Sat93
    Jun 18 '12 at 4:53
  • What version of Eclipse are you running?
    – Mitch
    Jun 18 '12 at 5:22
  • Please post the Log output.
    – user44136
    Jun 18 '12 at 5:36
1

Did you install Eclipse via the Ubuntu Software Center? Since it's never up to date there, you should donwload it from the Eclipse website. 3.7.2 is the latest, you seem to be running 3.7.0... After having unpacked the data to whatever place you want you can launch it by running the eclipse executable (purple with two gears for an icon). Unfortunately it doesn't really support being added to the launcher that way. You can of course create a desktop shortcut to the eclipse executable.

5
  • Download eclipse from official wevsite. Extract the folder in /usr/share . Create a launcher using eclipse.exe. Make sure this exe have the permission to run as program. Creating a launcher is easy. Open any file under /usr/share/applications using Gedit. Then copy the contents to a new file. Edit "Exec=/usr/share/Eclipse/eclipse". Change the name to Eclipse. Save it as "Eclipse.desktop" then cut/paste this file to /usr/share/applications Jun 18 '12 at 12:43
  • For more help regarding to creating a launcher check this-ubuntu-helpcenter.blogspot.com Jun 18 '12 at 12:44
  • ok. i got eclipse to launch by clicking the exe but I can't seem to launch it using the sudo command from the terminal. I'm trying to set up my computer for android app development. When I type 'sudo eclipse' it tells me the command is not found. any insight?
    – kreshendo
    Jun 18 '12 at 14:51
  • Are you able to run eclipse without the sudo? Try typing sudo -s which will let you use the terminal as a root user until closing it. Then try starting eclipse.
    – tpei
    Jun 18 '12 at 18:39
  • I created a launcher but I still cannot open eclipse with the sudo command to get root access. I tried Dragon5689's solution, it didn't work. any other bright ideas?
    – kreshendo
    Jul 1 '12 at 0:04
1

OK, the problem is that Eclipse IDE does not know where the swt library is located.

You need to help the software find it. You can see that by going to the log file on the error message.

Here is what I did to fix it:

ln -s /usr/lib/jni/libswt-* ~/.swt/lib/linux/x86_64/
0

Try this command again:

sudo apt-get install eclipse
0

just copy required libraries

sudo cp /usr/lib/jni/libswt-*3740.so ~/.swt/lib/linux/x86/

works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.