Did a ppa-purge of lucid-bleed and dpkg didn't downgrade properly and now it is broken.

dpkg: PreDepends: tar (>= 1.23) but 1.22-2ubuntu1 is to be installed

What scares me is when simulating the removal of dpkg I get:

Removing this package may render the system unusable. Are you sure you want to do that?

and then the list of packages which depend on it, which will also be removed, is obviously very long.

Is it safe for me to remove dpkg just to reinstall it? How would I ensure the list of packages which were also removed are then reinstalled?

Will forcing the version of dpkg help? (FYI: simulating a forced version brings up a much smaller list of applications which will also be removed).

Any other suggestions?

Additional information based on comments:

ppa-purge log: http://pastebin.com/1kT8cLvP

If I sudo apt-get install dpkg= I get

The following packages have unmet dependencies: libdpkg-perl: Depends: dpkg (>= 1.15.8) but is to be installed

which sucks because that means more would be broken after doing so...but when I force the version through Synaptic I get: To be removed alien, build-essential, cdbs, checkinstall, debhelper, devscripts, dpkg-dev, google-earth-stable, googleearth-package, libdpkg-perl, lintian, lsb, lsb-core, lsb-cxx, lsb-desktop, lsb-graphics, lsb-languages, lsb-multimedia, lsb-printing, lsb-qt4, lsb-security, ubuntu-dev-tools.

  • Removing dpkg will probably break your system. Please post logs of ppa-purge, and of the simulated force install you mention.
    – ish
    Jun 17, 2012 at 22:18

1 Answer 1


I was able to solve this with minimal impact to the system, its installed software and services, and its stability, by downloading the tar 1.23 source, compiling and installing it.

Then I was actually able to force downgrade dpkg sudo apt-get install dpkg=, which I wasn't even able to do, and all is back to normal! Phew!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .