67

How do I switch from the default display manager (Lightdm) to the older display manager (GDM)?

0

7 Answers 7

56
+100

Switching from LightDM to the "older" GDM is very easy, and need not even involve opening a terminal.

Note:

  • If you need/want to do this from a terminal (e.g. recovery console), please scroll below the screenshots for a how-to.
  • Also, the "new" GDM is not covered here because it is not officially available for 12.04 and the unofficial packages do not work for most users.

Easily switch to GDM with the Software Centre

  1. Open the Software Center, type "gdm" in the search box, and click on Install as shown below, or click on this button: gdm Install gdm

    enter image description here

  2. After you enter your password, you will get the configuration screen shown below. Change lightdm to gdm and click on Forward:

    enter image description here

  3. Restart your computer, and you should now have the "old" GDM login screen; note that you can still select from any available session, including Ubuntu (3D), Ubuntu 2D, Gnome, Gnome Classic, etc.

    enter image description here


Switch to GDM via the terminal

  1. Open a terminal with Ctrl+Alt+T if you are on the desktop and not in the recovery console.

  2. Type sudo apt-get install gdm, and then your password when prompted or run sudo dpkg-reconfigure gdm then sudo service lightdm stop, in case gdm is already installed.

  3. A "Package Configuration" dialog will be displayed; click OK to proceed to the below screen. Use the arrow-keys to select gdm instead of lightdm, press Tab to move to OK, and press Enter.

    enter image description here

  4. Reboot the computer (you can do this with sudo reboot if in the recovery console).

5
  • NOTICE that mateo said that it does not work for 12.04 - that has been my experience. Ron Aug 10, 2012 at 21:17
  • I'm sorry? These screenshots were taken on 12.04. Stock gdm works perfectly. All Mateo did was add the one-click install link...
    – ish
    Aug 11, 2012 at 0:52
  • In Ubuntu 16.04, if you want to switch from lightdm to gdm you need to type dpkg-reconfigure lightdm to bring up the dialog.
    – Sina
    Nov 2, 2016 at 21:33
  • Just a warning related to the terminal instructions for Ubuntu 16.04: when I did sudo service lightdm stop it shut down my window manager and then my computer. Make sure you have saved everything! :) Also I couldn't find "gnome display manager" in the software centre.
    – rmin
    May 16, 2017 at 23:57
  • Compared to dozens other who did not, this worked for 17.10 as well, thanks a lot! Oct 25, 2017 at 14:17
40

These did not work for me for newer versions of gdm. I had to use gdm3 instead of gdm

sudo dpkg-reconfigure gdm3

12

additionally to the answers, to use gdm3 and stop lightdm on Ubuntu 18.04:

sudo dpkg-reconfigure gdm3

systemctl stop lightdm
systemctl start gdm3
5

Gnome-display-manager is not broken in 12.04 (or at least it works fine for me), There is no need to reboot the machine. You ran the right commands, but maybe try it this way, also might want to sudo apt-get install gdm just to make sure you have the working version.

I ran sudo dpkg-reconfigure gdm then sudo service lightdm stop

after this you will need to press alt+f2 and login from command line. Then you will be able to start sudo service gdm start separably.

4

Choosing Between lightdm and gdm

Reverting from lightdm to gdm is extremely easy if you have not entered a wrong command in the terminal.

You just need to open the terminal and type the following command:

sudo dpkg-reconfigure lightdm

Enter your password and two dialog boxes will appear after one another (Similar to those which appeared while installing lightdm).

Press enter to select 'OK' for first dialog box and then choose between gdm and lightdm in the second dialog box.

Restart your PC.

Hope that helps!

2

additionally what luis alvez wrote above, for systemd managed systems (15.10 e.g.) use:

systemctl service stop lightdm
systemctl service start gdm

instead of

sudo service lightdm stop
0

If your seeing this it means that you have tried to install KDE or anyother desktop environment and didn't like it and tried to switch back to genome or you have messed with your desktop environment.

Don't worry I will help you out (techlifejournal / tech life journal is here to help you :))

Steps:

  1. Reboot your pc either by using this command sudo reboot or by manually pressing on power button.

  2. Durning boot please select ubuntu advance options.

  3. Now scroll down by pressing down arrow from your keyboard and select recovery mode.

  4. Once your in recovery menu scroll down by pressing down arrow from your keyboard and select dpkg repair broken packages and hit enter.

  5. it will aske for to press Y. just do it and wait untile it tells you to press enter and then u press enter.

  6. Now scroll down to grub Update gurb boot loader and press enter and Y if it asks you and then wait until it fix the grub and then hit enter if it ask you do it.

( for your clarity we have fix packages and grub by following the above steps)

7.now you need to scroll up to resume resume normal boot and hit enter. it will take you to terminal and it will ask you to login.

  1. so login with your username and password.

  2. Now enter this commands carefully and slowly.

  3. sudo apt update && sudo apt upgrade -f --> to update all packages.

    sudo apt-get install lightdm --> to install light dm. this file may got corrupted which is causing the issues. so we are fixing it first.

    if it show a menu to choose gdm and lightdm please choose lightdm and hit enter.

  4. sudo apt-get install gdm3

    if it show a menu to choose gdm and lightdm please choose gdm and hit enter.

  5. sudo dpkg-reconfigure lightdm

     if it show a menu to choose gdm and lightdm please choose gdm and hit enter.
    
  6.  sudo systemctl stop lightdm  --> we are stop lightdm so that our boot loader can't use it.
    
  7. sudo systemctl start gdm3 --> we are trying to start gdm3 so that our boot loader can use it.

  8. sudo dpkg-reconfigure gdm3 --> choose gdm and hit enter

  9. sudo service lightdm stop --> trying to stop all the services so that it can't be used by boot loader.

  10. sudo service gdm3 start or sudo service gdm start --> it will start the services of gdm3 for boot loader.

  11. sudo reboot

  12. After rebooting please choose ubuntu and hit enter and wait it will start genome3. you can verify it by seeing the login page where it will use the username at the center of the screen.

if your seeing username or login at the left bottom of the screen then it means your using lightdm not genome. please stop it by using the above commands.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.