195

Sometimes the pulseaudio service stops and it doesn't restart itself when I open an audio file with banshee or totem.

How I can make pulseaudio start again without having to logout?

2
  • 2
    Could I be so bold as to suggest accepting TikTak's answer? It works for me whereas the answer with the most upvotes has extra unnecessary steps. Apr 29 '18 at 0:50
  • TikTak's answer is not the way one should restart PulseAudio in Ubuntu 2020 releases. systemctl should be used to restart PulseAudio.
    – kas
    Nov 1 '20 at 19:47
209

I solved my problem.

  1. Check if any pulseaudio instance is running:

    pulseaudio --check
    

    It normally prints no output, just exit code. 0 means running. Mine were not running, so I just advanced to step 3.

  2. If any instance is running:

    pulseaudio -k
    
  3. Finally, start pulseaudio again as a daemon:

    pulseaudio -D
    
  4. Start banshee again and enjoy!

5
  • 3
    For me --check didn't show anything, even though -k stopped audio playback, implying pulseaudio was running.
    – Cerin
    Apr 24 '15 at 19:24
  • 6
    For me, pulseaudio gets so hung up (forgetting a sink) that pulseaudio -k doesn't do the job. After sudo killall pulseaudio, everything starts up again and works fine. (Ubuntu 16.04)
    – Raphael
    Nov 17 '17 at 13:01
  • 6
    fyi, the step 1: "pulseaudio --check normally prints no output, just exit code 0 which means running" => so, there is no output, it's running; but, if you want to check the exit code anyway, run: echo $? which should print 0 if it's running. (the $? is the exit code of the previous command. If you run it twice, then it prints the exit code of echo)
    – michael
    Dec 7 '17 at 6:15
  • You could combine steps 1 and 2 like so: pulseaudio --check && pulseaudio -k - it will only run the kill if check exits with 0 (running)
    – Jeff Ward
    Dec 1 '20 at 17:32
  • Combining Raphael and Jeff's observations, I frequently find myself running pulseaudio --check && (pulseaudio -k || sudo killall pulseaudio)
    – Nick Bull
    Jul 5 at 14:46
56

In a standard setup running pulseaudio -k restarts the daemon. Nothing else to do.

In case pulseaudio is not running typing pulseaudio without further options will start the daemon using defaults in /etc/pulse/daemon.conf and /etc/pulse/default.pa.

User-defined settings in ~/.pulse/ or ~/.config/pulse/ will override system-wide settings. In case of issues it will often help to delete these directories before restarting pulseaudio.

For details see PulseAudio Wiki.

5
  • /usr/bin/pulseaudio returns bash: /usr/bin/pulseaudio: Permission denied even though the file permissions seem fine: -rwxr-xr-x+ 1 root root 87K Jun 21 08:09 /usr/bin/pulseaudiowhy Jul 21 '17 at 9:27
  • because the daemon is running as root Mar 20 '18 at 15:07
  • rm ~/.config/pulse/* followed by pulseaudio -k did the trick. Mar 31 '18 at 18:52
  • @Takkat What ?? pulseaudio -k kills the daemon, period. The manpage is very clear on that. You have to run pulseaudio --start afterwards to start the daemon.
    – Atralb
    Dec 21 '20 at 6:42
  • @Atralb did you try my answer? As stated, in it's default installation pulseaudio will respawn automatically. If you then try to start the server a second time it will give you an error. If respawning was broken you may have a serious issue with your audio setup.
    – Takkat
    Dec 21 '20 at 8:00
49

Pulseaudio is a user service, so:

systemctl --user restart pulseaudio.service

Also there is this:

systemctl --user restart pulseaudio.socket

For checks replace restart with status.

3
  • 4
    To be run as normal user, the user which runs pulseaudio of course. Should be the top answer. And I have to say that for me pulseaudio was functioning well. But after some libraries where upgraded it had to be restarted.
    – Stéphane
    Aug 18 '19 at 14:28
  • 1
    This is the right answer for me. pulseaudio -k does or returns nothing at all. The other option that worked was killall pulseaudio.
    – nyxee
    May 8 '20 at 20:05
  • 3
    This is the correct answer for Ubuntu & other distros using SystemD to launch PulseAudio as a logged in user.
    – TrinitronX
    Jul 25 '20 at 19:04
12

Use the service command (Ubuntu 14.04 or older only):

sudo service pulseaudio restart
4
  • I unfortunately don't have any specific knowledge in addition to the very explicit command. If if had, I would have had explained more. If you have any idea, please be my guest.
    – PowerKiKi
    Mar 2 '15 at 13:40
  • 34
    Ubuntu 16.04: Failed to restart pulseaudio.service: Unit pulseaudio.service not found. Apr 11 '17 at 18:58
  • 2
    pulseaudio runs in user mode (i.e. the currently logged-in user), no "service" registered. So that command cannot work.
    – Izzy
    Oct 17 '18 at 15:27
  • Indeed, pulseaudio runs in user mode. See my answer
    – Rolf
    Mar 7 '19 at 20:17
10

Following works for me on Ubuntu 18.04:

pulseaudio -k && sudo alsa force-reload
2
  • This just kills the sound completely.
    – mathtick
    Aug 21 '20 at 14:04
  • @mathtick for me, 'pulseaudio -D' worked afterwards to restore the missing audio. This starts pulseaudio again.
    – mkV
    Jan 15 at 17:07
9

Here's how to do it in Ubuntu 15.10:

  1. Launch Terminal
  2. Run pulseaudio -k to kill the running daemon. You will get an error only if no daemon was running, otherwise no messages will appear.
  3. Ubuntu will attempt to restart the daemon automatically assuming there are no problems with the configuration. You can run pulseaudio --check to check that Pulseaudio is running. A clean exit (no message) from the check command indicates that the daemon has started successfully. Otherwise, run pulseaudio --start to launch the daemon. If you recently changed your configuration file and the daemon fails to start, check your file for errors and check the syslog (with the SystemLog app) for any messages from Pulseaudio.
5

If the pulseaudio failing to work is related to S3 sleep (Suspend to RAM), the real cause may be audio hardware problem and then you have to do heavy-handed full reset:

pulseaudio -k && sudo alsa force-reload && sleep 2 && pulseaudio -k && sudo alsa force-reload

Yeah, it needs to be done twice with small delay. I don't know why but this seems to work every time.

If you have multiple desktop environments in parallel (fast user switching)

sudo killall pulseaudio && sudo alsa force-reload && sleep 2 && sudo killall pulseaudio && sudo alsa force-reload
5

Run the following commands:

pulseaudio --check
pulseaudio --kill
pulseaudio --start
3

You would run this command to restart PulseAudio in Ubuntu 2020 releases:

systemctl --user restart pulseaudio
1
  • 2
    finally, a command that works on ubuntu 20. Also not sure what caused the service to not restart itself after reboot, but it happened after a recent update.
    – lasec0203
    Nov 8 '20 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.