Fellas, need help. Trying to install Ubuntu 12.04 on laptop to dual boot alongside Win7. I have UEFI and GPT partitioning scheme. It has optional Legacy boot mode though. I can boot from Ubuntu USB/CD in both Legacy and UEFI modes. But when I reach partition selection step, it gives me error "ubi-partman failed with exit code 141". I searched forums for this but those who encountered this error said it was resolved when they detached one of two HDs in their system. But I have only one hard disk attached and I am sure Ubuntu's GRUB supports GPT. But looks like it is not able to read GPT partitions on my HD. Any help regarding this will be appreciated.

  • In what mode are you trying to install Ubuntu when you get this error? UEFI or legacy (CSM)? What partitions are on your drive? – irrational John Jun 17 '12 at 16:26
  • 1
    Details of your current partitioning setup are critical. If you can boot from an emergency system and type sudo parted /dev/sda unit s print, that will give you the partitioning information needed to begin diagnosing this problem. – Rod Smith Jun 17 '12 at 16:37
  • I am a newbie to GPT and EFI stuff actually. But I think out of 11 partitions 1st is some 260MB OEM Partition, 2nd is 16GB usual Recovery Partition, 3rd is 260MB EFI System Partition, next is Win 7 Partition, and others are data partitions I created. Also, I have tried Ubuntu installation in both UEFI and Legacy methods. But same error. And from what I learned from GPartED, all my partitions are GPT partitions. I have Sony Vaio laptop (sony.co.in/product/sve14a15fn). It has American Megatrends Aptio BIOS. – aniruddha-ix Jun 17 '12 at 19:58
  • @RodSmith: I have also put your rEFInd boot loader in my EFI partition and then tried ubuntu installation. But i encountered same error. I am actually a newbie to Linux operations and to EFI. – aniruddha-ix Jun 17 '12 at 20:02
  • Please post the output of sudo parted /dev/sda unit s print, as I requested. A verbal description of your partitions, as you've provided, gives some of the information from the actual program output, but there are many more details in the actual program output. For instance, the program's output will show precise start and end points for the partitions; these could be messed up in any of a number of ways that your verbal description won't help diagnose. – Rod Smith Jun 17 '12 at 21:55

Your parted output suggests you've got a partition table problem, or at least an issue that libparted (which is used both by the text-mode parted program and the Ubuntu partitioner) is interpreting as a partition table problem. The "Invalid or incomplete multibyte or wide character" message suggests that parted is having problems interpreting the partition name, which is officially a UTF16-encoded name. Unfortunately, the last time I checked, parted didn't do proper UTF-16 encoding or decoding of partition names; instead, it tried to interpret them as a sort of modified ASCII -- or in practice, a modified UTF-8. This could lead to problems if a real UTF-16 partition name used non-ASCII characters, since they might then look like gibberish when interpreted as a modified UTF-8. Since libparted is very sensitive to errors and offers little in the way of corrective tools, the result is an error, as both parted and the Ubuntu installer demonstrate.

If I'm right (and I'm far from certain that I am), you should be able to correct the problem as follows:

  1. Boot into the Ubuntu (or any other Linux) rescue disk.
  2. If necessary, download and install GPT fdisk (gdisk). It's available as the gdisk package in Ubuntu.
  3. Type sudo gdisk /dev/sda to launch gdisk on your problem disk.
  4. Type v to verify the disk's data structures. If gdisk reports any problems, it could be that parted was reacting to some problem other than the partition name, and that may need to be dealt with instead of (or at least before) proceeding with the below steps.
  5. Type p to view your partition table. Look for any non-ASCII characters in the "Name" column.
  6. Type c to change the name of any partition that has a strange name. You'll be asked for a partition number and a new name. Repeat this for as many partitions as necessary (up to all of them).
  7. Type p to review your partition table to be sure everything looks sane.
  8. If everything looks good, type w to save your changes and exit from gdisk.

If my suspicion is correct, you should now be able to proceed with Ubuntu installation. If I'm correct, this is a libparted bug, which should be reported to Ubuntu and/or to the libparted developers. Recording the names of all your partitions for inclusion in your bug report is worth doing.

  • Let me explain what happened after following above procedure: You nailed it. :).. The solution worked like a charm. Thanks a lot! Now that I am able and about to install Ubuntu, I have another doubt about the same. While selecting partition to install Ubuntu Bootloader, which partition should I select? Since EFI scheme stores all the bootloaders on a single partition, am I supposed to select EFI system partition or Ubuntu partition like old times? Once again, THANK YOU VERY MUCH for the solution. – aniruddha-ix Jun 20 '12 at 19:37
  • I'm glad that's resolved your primary problem. As to the new one, my vague recollection is that the install target for the boot loader is ignored in EFI mode; however, I may be thinking of another distribution. Try either the main device (/dev/sda) or the ESP (usually /dev/sda1). – Rod Smith Jun 21 '12 at 0:43

Use Wubi Ubuntu iso to install Ubuntu to dual boot with Windows. I had done so and it worked fine. You can also uninstall it from Windows itself.

  • Tried. I've tried Ubuntu bootable CD, USB drive and install inside Windows all three methods. Got same error everytime.. – aniruddha-ix Jun 17 '12 at 19:48

I have a Sony Vaie SeriesE, 14". I ve had some kind of similar problems than anhiruddabhide.

So far, I have taken the hard disk with the Win 7 out and add a new one on which I installed Ubuntu. No problem. Of course, it is not a solution that would have made aniruddhabhide happy.

Now the funny thing is that Ubuntu was UNABLE to start when the EFI option was set up in the BIOS. So I turned it to Legacy.

Legacy works for me real good. Nevertheless, nearly each time, the computer does not boot "No system found". After CTRL+ALT+SUPP, computer reboots and the Grub kicks in. I have to say it is not GRUB nor UBUNTU's fault, but some wicked stuff in the SOny BIOS which is far from satisfying (hardly any option available).

I'll try two things and keep you posted:

  1. Reinstall the Ubuntu partition on a bigger hard disk contianing a copy of the SONY's VAIO original hard disk.

  2. Install a slim rack DVDreplacement in order to put a second hard disk instead of the DVD player installed by VAIO. That way I'll have two hard disks, which is way better for backups and combining systems (Windows + Ubuntu for instance).

  • @Eliah Kagan Were you able to solve the issue? Also, after installing Ubuntu (in GPT), did you try copying Ubuntu's grub.efi/grub64.efi? Make sure you maintain the directory hierarchy in ESP while doing so. – aniruddha-ix Oct 9 '12 at 7:34
  • @aniruddhabhide I didn't experience this problem--I just edited this answer, to improve its formatting. Did you mean to ask @papayou? – Eliah Kagan Oct 9 '12 at 7:40
  • Ohh.. Sorry.. Yes, I meant to ask @papayou. – aniruddha-ix Oct 9 '12 at 9:30

Ubuntu doesn't recommend using wubi any longer.


  • 1
    While this may be the link to the correct answer, it would be better if you could also give a brief description of why this link would answer their question. – SimplySimon Sep 20 '13 at 7:32

Some ASUS models use Aptio firmware from American Megatrends. It appears the BIOS is case sensitive. It looks for the filename EFI/BOOT/bootx64.efi, but Ubuntu provides EFI/BOOT/BOOTX64.EFI. See https://bugs.launchpad.net/linux/+bug/1261465.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.