I have 2 "data" drives. One is ntfs, the other is ext4.

The Trash works for both drives when I allow Nautilus to handle the mount.

I've opted to auto-mount them via entries in /etc/fstab, but when I do this, only the ext4 gives me a functioning Trash directory.

Trash on the ntfs drive simply does not work.
When I press "delete" or use the context menu item "Move to Trash", I get this error dialog message.

Cannot move file to trash, do you want to delete immediately?
. . . . The file "test" cannot be moved to the trash . . . .

Here are my /etc/fstab lines.

/dev/sdb1 /media/D_0931_data   ntfs  defaults  0   0  
/dev/sdc1 /media/E_0298_back   ext4  defaults  0   0  

... and here is how I created the mountpoint directories.

sudo mkdir  /media/D_0931_data  
sudo mkdir  /media/E_0298_back  

Everything seems to be working fine, except for the Trash on the ntfs drive...
The Trash on the ext4 drive works normally.

UPDATE: more info about ownership change after sudo mount -a

sudo mkdir  /media/D_0931_data
sudo mkdir  /media/E_0298_back
ls -la      /media
  drwxr-xr-x  2 root root 4096 2010-11-28 10:27 D_0931_data
  drwxr-xr-x  2 root root 4096 2010-11-28 10:27 E_0298_back
gksu gedit  /etc/fstab
  /dev/sdb1 /media/D_0931_data   ntfs  defaults  0   0
  /dev/sdc1 /media/E_0298_back   ext4  defaults  0   0
sudo mount -a
ls -la      /media
  drwxrwxrwx  1 root root  12288 2010-11-28 10:22 D_0931_data
  drwxrwxr-x  5 root axiom  4096 2010-11-28 09:51 E_0298_back

I believe Nautilus needs a .Trash-1000 folder in the root of the filesystem (e.g. /media/D_0931_data/.Trash-1000) to exist and be user-writeable.

NOTE: the 1000 in the .Trash-1000 is your user ID. You can get yours by id -u USERNAME. Change it accordingly if needed.

Try running this: sudo mkdir /media/D_0931_data/.Trash-1000; sudo chmod 777 /media/D_0931_data/.Trash-1000.

If that didn't work, can you try the same but with .Trash instead of Trash-1000, and if that didn't work, post the output of ls -la /media/D_0931_data?

Try adding this to fstab (on the ntfs line): defaults,uid=1000 instead of just defaults.

  • I approximately followed what you've said.. and the most significant(?) thing I've seen is that the ownership and permission of the the mountpoint folders change after sudo mount -a ... I don't know how to interpret this... (I've added the steps to my question)... Re the .Trash directory, I couldn't change permissions (strange!)
    – Peter.O
    Nov 27 '10 at 23:47
  • I assume that the permissions change because of my "default" entry in /etc/fstab ... but ntfs is quite different to ext4.
    – Peter.O
    Nov 27 '10 at 23:56
  • Ah, of course, there are no permissions on ntfs. Silly me.
    – evgeny
    Nov 28 '10 at 0:14
  • 2
    evgeny: Marvleous! You've saved the day! .... it works now (with uid=1000) ... Thanks.
    – Peter.O
    Nov 28 '10 at 2:04
  • 1
    adding this to fstab partition line solved the problem ntfs-3g defaults,umask=077,uid=1000,gid=100,users,exec,noauto,noatime 0 0 Jun 25 '13 at 1:57

As far as I know this is a bit of a bug in nautilus, maybe you could report it? I've experienced this as well and as far as I understand it is one of those silly "features" of nautilus, where it does something in a way it really should not by logic.

It seems to be related to the way nautilus "understands" the automounted drive; it sees it as being non-native somehow and disables some features (a safety "feature"). As I said earlier, the best option here is to report a bug on nautilus.

  • It seems that Nautilus handles the Trash perfectly well when it mounts the ntfs drive, by me clicking on the drive "label" in Places.. I've been assuming that Nautilus would not be involved at all if I auto-mount via /etc/fstab, but I "think" that perhaps Nautilus is the app which actually manages the Trash... If that is the case, then there could well be some odd interaction.. I'll have to look at it a bit more later.. this is spinning me out (need a break).. If I pinpoint that it is not something I've done incorrectly, I'll try to report a bug, but is it Bugzilla or Launchpad or...??
    – Peter.O
    Nov 28 '10 at 0:45
  • better bugzilla since it could be dealt with upstream at once, but if you want a faster/more friendly response launchpad is generally better (though there is the risk upstream would deny any patches simply because they come from Canonical).
    – RolandiXor
    Nov 28 '10 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.