I've just installed Ubuntu 12.04 on an Asus G55V laptop and neither the laptop brightness control keys (FN+F5, FN+F6) nor the Brightness setting are able to control the backlight.

Note that I've installed the nvidia-current driver, as the laptop is equiped with a GeForce GTX 660M, and it's working fine.

So far here is what have tried to no avail:

  • Switch to a console (Alt+F1) and use the laptop brightness control keys (this method was working with 10.04 and Lenovo T410),
  • echo 2 > /sys/class/backlight/acpi_video0/brightness,
  • Added GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" to /etc/default/grub and updated Grub config,
  • Also tried without acpi_osi=Linux.

Out of all these attempts, one thing changed: if I change the brightness in the BIOS bootloader right before booting on the HDD, the brightness setting stays the same in Ubuntu. This is an acceptable temporary workaround but I would really like to be able to control the backlight brightness from Ubuntu (can be from command line, fine with me).

Any suggestions on what to try next would be highly appreciated.

  • were you able to run the second command echo 2 > .. successfully? What is output of ls /sys/class/backlight/*/brightness – Web-E Jun 20 '12 at 13:15
  • Yes, the command was working before I tried the Grub change but wasn't changing the backlight intensity. Currently, the output of the ls command you asked is No such file or directory. – David Dossot Jul 9 '12 at 1:50
  • Removed acpi_backlight=vendor from grub and re-run the ls command which now gives /sys/class/backlight/acpi_video0/brightness. Echoing numbers to it produces no error but also no brightness change. – David Dossot Jul 9 '12 at 2:07

Try with: https://github.com/guillaumezin/nvidiabl


wget https://github.com/downloads/guillaumezin/nvidiabl/nvidiabl-dkms_0.76_all.deb
sudo dpkg -i nvidiabl-dkms_0.76_all.deb
sudo modprobe nvidiabl

Print current brightness value

cat /sys/class/backlight/nvidia_backlight/actual_brightness

Print maximun brightness value

cat /sys/class/backlight/nvidia_backlight/max_brightness

Adjust brightness

echo 50 | sudo tee /sys/class/backlight/nvidia_backlight/brightness
  • Things go fine until sudo modprobe nvidiabl which dies with FATAL: Error inserting nvidiabl (/lib/modules/3.2.0-25-generic-pae/updates/dkms/nvidiabl.ko): No such device. – David Dossot Jul 9 '12 at 1:56
  • Same error occurs even after removing acpi_backlight=vendor from grub. – David Dossot Jul 9 '12 at 2:11
  • 1
    Seems that your device isn't recognized by nvidiabl, and it is expected if you have a really new hardware. I suggest you to open a ticket at github.com/guillaumezin/nvidiabl/issues reporting your hardware spec. For geeky users, it is possible to debug driver by himself as explained in the README. – Giovanni Toraldo Jul 9 '12 at 7:25
  • Works fine with version 0.76 of the package! I updated your answer to show this version for future readers. Thanks! – David Dossot Jul 11 '12 at 21:32
  • FTR: Version 0.87 works great with 14.04. – David Dossot Nov 9 '14 at 17:19

try to execute the following command:

/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 3

replace 3 with something between 0 and max-brightness. You can find out what max-brightness is by running following command:

/usr/lib/gnome-settings-daemon/gsd-backlight-helper --get-max-brightness

  • Using gsd-backlight-helper returns ** (gsd-backlight-helper:3040): WARNING **: failed to find any devices. – David Dossot Jul 9 '12 at 1:52
  • After removing acpi_backlight=vendor from grub, the commands run. Max brightess returns 10 and set-brigthness returns no error but doesn't change the backlight brightness. – David Dossot Jul 9 '12 at 2:09
  • sorry pal... worked for me, when other suggestions did not. – Yevgeniy M. Jul 9 '12 at 7:12
  • Thanks a lot! This worked for me, the only thing that does not work is the FN + F8 or F9. I wonder if I can fix this ? All the other FN combinations work properly. I'm on a custom computer Clevo W370ET with nvidia gtx660m – punkbit Oct 9 '12 at 19:11

I had similar problem with Asus P50IJ notebook and Ubuntu 14.04. After i add the kernel boot parameter "acpi_backlight=vendor" the function keys works again.

You can use this command:

 sudo sed -i 's|quiet splash|acpi_backlight=vendor quiet splash|g' /etc/default/grub
 sudo update-grub

Don´t forget to reboot you notebook after that.


Try this It just might work as long as the keys are ACPI ones... Personally, I still get: "failed to find any devices" but still working on it...

  • It is preferable if a summary is posted here and the link provided for further reference. Answers with just links are not encouraged on Ask Ubuntu – Mahesh Sep 18 '13 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.