4

After an update a couple of days ago, Okular, which I have been using otherwise successfully for some time, stopped displaying any window when opened. The dock and the list of active processes tell that the program is running. This occurs after the program having been opened and closed a a few times. Restarting the computer does not help. If I uninstall and reinstall, I get back the normal functioning for a few sessions and then the behaviour returns. Did anyone experience something similar and does anyone know what is going on? I am running Ubuntu 24.04 and the Okular version is 24.05.1. From the command line, I can produce the following dialog.

$ okular (some PDF file)
kf.windowsystem: static int KX11Extras::currentDesktop() may only be used on X11

** (okular:(process ID)): WARNING **: (time stamp): atk-bridge: get_device_events_reply: unknown signature

Nothing more happens before I break with ^C. Entering only

$ okular

results in just the warning. No program window occurs.

1 Answer 1

3

Remove the snap okular and use the APT version (slightly older, but stable). Open a terminal and enter the following commands one by one:

sudo snap remove okular
sudo apt install okular
4
  • Thanks. Seems to solve the issue. Commented Jun 16 at 9:50
  • @KaiNeergård You can accept my answer by clicking the checkmark if it solves the issue. Commented Jun 16 at 12:56
  • apt install is asking me to install 230 new packages for it. Is it normal?
    – Miraz
    Commented Jul 13 at 8:23
  • @Miraz Okular is a KDE package, and needs a lot of KDE backends, which are not preinstalled in Ubuntu (they are preinstalled in Kubuntu or Lubuntu). It is normal. Commented Jul 13 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .