0

Basically libreoffice packages fail after installing and wont start. And I need to sudo dpkg --purge --force-remove-reinstreq them to remove them because of "dependency problems" if i try with apt or without --force-remove-reinstreq (some work without because of pi status) Most of the messages are like this:

x depends on y; however: Package y is not configured yet

and this:

dpkg: error processing package z (--configure): dependency problems - leaving unconfigured

Install log:

(Reading database ... 106794 files and directories currently installed.)
Preparing to unpack .../00-liblibreoffice-java_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking liblibreoffice-java (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-style-colibre.
Preparing to unpack .../01-libreoffice-style-colibre_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-style-colibre (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-common.
Preparing to unpack .../02-libreoffice-uiconfig-common_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-common (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-common.
Preparing to unpack .../03-libreoffice-common_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-common (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-core.
Preparing to unpack .../04-libreoffice-core_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-core (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-base-core.
Preparing to unpack .../05-libreoffice-base-core_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-base-core (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-base-drivers.
Preparing to unpack .../06-libreoffice-base-drivers_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-base-drivers (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-base.
Preparing to unpack .../07-libreoffice-uiconfig-base_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-base (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-base.
Preparing to unpack .../08-libreoffice-base_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
No diversion 'diversion of /usr/lib/libreoffice/share/basic/dialog.xlc to /usr/lib/libreoffice/share/basic/dialog.xlc.noaccess by libreoffice-base', none removed.
No diversion 'diversion of /usr/lib/libreoffice/share/basic/script.xlc to /usr/lib/libreoffice/share/basic/script.xlc.noaccess by libreoffice-base', none removed.
Unpacking libreoffice-base (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-calc.
Preparing to unpack .../09-libreoffice-uiconfig-calc_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-calc (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-calc.
Preparing to unpack .../10-libreoffice-calc_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-calc (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-draw.
Preparing to unpack .../11-libreoffice-uiconfig-draw_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-draw (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-impress.
Preparing to unpack .../12-libreoffice-uiconfig-impress_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-impress (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-draw.
Preparing to unpack .../13-libreoffice-draw_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-draw (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-impress.
Preparing to unpack .../14-libreoffice-impress_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-impress (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-math.
Preparing to unpack .../15-libreoffice-uiconfig-math_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-math (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-math.
Preparing to unpack .../16-libreoffice-math_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-math (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-report-builder-bin.
Preparing to unpack .../17-libreoffice-report-builder-bin_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-report-builder-bin (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-writer.
Preparing to unpack .../18-libreoffice-uiconfig-writer_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-writer (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-writer.
Preparing to unpack .../19-libreoffice-writer_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-writer (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package python3-uno.
Preparing to unpack .../20-python3-uno_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking python3-uno (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice.
Preparing to unpack .../21-libreoffice_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-gnome.
Preparing to unpack .../22-libreoffice-gnome_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-gnome (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-gtk3.
Preparing to unpack .../23-libreoffice-gtk3_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-gtk3 (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-java-common.
Preparing to unpack .../24-libreoffice-java-common_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-java-common (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-uiconfig-report-builder.
Preparing to unpack .../25-libreoffice-uiconfig-report-builder_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-uiconfig-report-builder (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-report-builder.
Preparing to unpack .../26-libreoffice-report-builder_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-report-builder (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-script-provider-bsh.
Preparing to unpack .../27-libreoffice-script-provider-bsh_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-script-provider-bsh (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-script-provider-js.
Preparing to unpack .../28-libreoffice-script-provider-js_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-script-provider-js (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-script-provider-python.
Preparing to unpack .../29-libreoffice-script-provider-python_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-script-provider-python (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-sdbc-firebird.
Preparing to unpack .../30-libreoffice-sdbc-firebird_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-sdbc-firebird (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-sdbc-hsqldb.
Preparing to unpack .../31-libreoffice-sdbc-hsqldb_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-sdbc-hsqldb (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-sdbc-mysql.
Preparing to unpack .../32-libreoffice-sdbc-mysql_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-sdbc-mysql (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-sdbc-postgresql.
Preparing to unpack .../33-libreoffice-sdbc-postgresql_4%3a24.2.3-0ubuntu0.24.04.2_amd64.deb ...
Unpacking libreoffice-sdbc-postgresql (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-style-elementary.
Preparing to unpack .../34-libreoffice-style-elementary_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-style-elementary (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-style-yaru.
Preparing to unpack .../35-libreoffice-style-yaru_4%3a24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-style-yaru (4:24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-wiki-publisher.
Preparing to unpack .../36-libreoffice-wiki-publisher_4%3a1.2.0+LibO24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-wiki-publisher (4:1.2.0+LibO24.2.3-0ubuntu0.24.04.2) ...
Selecting previously unselected package libreoffice-nlpsolver.
Preparing to unpack .../37-libreoffice-nlpsolver_4%3a0.9+LibO24.2.3-0ubuntu0.24.04.2_all.deb ...
Unpacking libreoffice-nlpsolver (4:0.9+LibO24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-style-yaru (4:24.2.3-0ubuntu0.24.04.2) ...
Processing triggers for desktop-file-utils (0.27-2build1) ...
Setting up libreoffice-uiconfig-draw (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-uiconfig-writer (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-uiconfig-report-builder (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-uiconfig-base (4:24.2.3-0ubuntu0.24.04.2) ...
Processing triggers for bamfdaemon (0.5.6+22.04.20220217-0ubuntu5) ...
Setting up libreoffice-uiconfig-impress (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-uiconfig-common (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-uiconfig-math (4:24.2.3-0ubuntu0.24.04.2) ...
Processing triggers for man-db (2.12.0-4build2) ...
Processing triggers for shared-mime-info (2.4-4) ...
Setting up libreoffice-style-colibre (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up liblibreoffice-java (4:24.2.3-0ubuntu0.24.04.2) ...
Processing triggers for gnome-menus (3.36.0-1.1ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up libreoffice-uiconfig-calc (4:24.2.3-0ubuntu0.24.04.2) ...
Setting up libreoffice-common (4:24.2.3-0ubuntu0.24.04.2) ...
dpkg: error processing package libreoffice-common (--configure):
 installed libreoffice-common package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of libreoffice-impress:
 libreoffice-impress depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-impress (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base:
 libreoffice-base depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-math:
 libreoffice-math depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-math (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a fo
llowup error from a previous failure.
                                     No apport report written because MaxReports is reached already
                                                                                                   dpkg: dependency problems prevent configuration of libreoffice:
 libreoffice depends on libreoffice-base; however:
  Package libreoffice-base is not configured yet.
 libreoffice depends on libreoffice-impress; however:
  Package libreoffice-impress is not configured yet.
 libreoffice depends on libreoffice-math; however:
  Package libreoffice-math is not configured yet.

dpkg: error processing package libreoffice (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-sdbc-postgresql:
 libreoffice-sdbc-postgresql depends on libreoffice-common (>= 1:7.0.0~alpha); however:
  Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-sdbc-postgresql (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            dpkg: dependency problems prevent configuration of 
libreoffice-report-builder-bin:
 libreoffice-report-builder-bin depends on libreoffice-base; however:
  Package libreoffice-base is not configured yet.

dpkg: error processing package libreoffice-report-builder-bin (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-core:
 libreoffice-core depends on libreoffice-common (>> 4:24.2.3); however:
  Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-calc:
 libreoffice-calc depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.
 libreoffice-calc depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.

No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            dpkg: error processing package libreoffice-calc (--
configure):
 dependency problems - leaving unconfigured
Setting up libreoffice-style-elementary (4:24.2.3-0ubuntu0.24.04.2) ...
dpkg: dependency problems prevent configuration of libreoffice-sdbc-mysql:
 libreoffice-sdbc-mysql depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-sdbc-mysql (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-uno:
 python3-uno depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.
 python3-uno depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2) | libreoffice-core-nogui (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.
  Package libreoffice-core-nogui is not installed.

dpkg: error processing package python3-uno (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreofficeNo apport report written because MaxReports is reached already
                                                                                                                            No apport report written because MaxReports is reac
hed already
           No apport report written because MaxReports is reached already
                                                                         -base-drivers:
 libreoffice-base-drivers depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-base-drivers (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-report-builder:
 libreoffice-report-builder depends on libreoffice-common (>= 1:7.0.0~alpha); however:
  Package libreoffice-common is not configured yet.
 libreoffice-report-builder depends on libreoffice-core | libreoffice-core-nogui; however:
  Package libreoffice-core is not configured yet.
  Package libreoffice-core-nogui is not installed.
 libreoffice-report-builder depends on libreoffice-report-builder-bin (>= 4:24.2.3); however:
  Package libreoffice-report-builder-bin is not configured yet.

dpkg: error processing package libreoffice-report-builder (--configure):
 dependency problemsNo apport report written because MaxReports is reached already
                                                                                  No apport report written because MaxReports is reached already
                                                                                                                                                 - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-gtk3:
 libreoffice-gtk3 depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-gtk3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-script-provider-bsh:
 libreoffice-script-provider-bsh depends on libreoffice-common; however:
  Package libreoffice-common is not configured yet.
 libreoffice-script-provider-bsh depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-script-provider-bsh (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-gnome:
 libreoffice-gnome depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.
 libreoffice-gnome depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-gnome (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-nlpsolver:
 libreoffice-nlpsolver depends on libreoffice-calc; however:
  Package libreoffice-calc is not configured yet.
 libreoffice-nlpsolver depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-nlpsolver (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-draw:
 libreoffice-draw depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.
 libreoffice-draw depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-draw (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-script-provider-js:
 libreoffice-script-provider-js depends on libreoffice-common; however:
  Package libreoffice-common is not configured yet.
 libreoffice-script-provider-js depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-script-provider-js (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            dpkg: dependency problems prevent configuration of 
libreoffice-writer:
 libreoffice-writer depends on libreoffice-common (>= 1:7.0.0~alpha~); however:
  Package libreoffice-common is not configured yet.
 libreoffice-writer depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-writer (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-java-common:
 libreoffice-java-common depends on libreoffice-common; however:
  Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-java-common (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-script-provider-python:
 libreoffice-script-provider-python depends on libreoffice-common; however:
  Package libreoffice-common is not configured yet.
 libreoffice-script-provider-python depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.
 libreoffice-script-provider-python depends on python3-uno; however:
  Package python3-uno is not configured yet.

dpkg: error processing package libreoffice-script-provider-python (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-sdbc-firebird:
 libreoffice-sdbc-firebird depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.

dpkg: error processing package libreoffice-sdbc-firebird (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-wiki-publisher:
 libreoffice-wiki-publisher depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
 libreoffice-wiki-publisher depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-wiki-publisher (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-base-core:
 libreoffice-base-core depends on libreoffice-core (= 4:24.2.3-0ubuntu0.24.04.2) | libreoffice-core-nogui (= 4:24.2.3-0ubuntu0.24.04.2); however:
  Package libreoffice-core is not configured yet.
  Package libreoffice-core-nogui is not installed.

dpkg: error processing package libreoffice-base-core (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb depends on libreoffice-core-nogui | libreoffice-core; however:
  Package libreoffice-core-nogui is not installed.
  Package libreoffice-core is not configured yet.
 libreoffice-sdbc-hsqldb depends on libreoffice-java-common (>= 4:24.2.3~); however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-sdbc-hsqldb (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 libreoffice-common
 libreoffice-impress
 libreoffice-base
 libreoffice-math
 libreoffice
 libreoffice-sdbc-postgresql
 libreoffice-report-builder-bin
 libreoffice-core
 libreoffice-calc
 libreoffice-sdbc-mysql
 python3-uno
 libreoffice-base-drivers
 libreoffice-report-builder
 libreoffice-gtk3
 libreoffice-script-provider-bsh
 libreoffice-gnome
 libreoffice-nlpsolver
 libreoffice-draw
 libreoffice-script-provider-js
 libreoffice-writer
 libreoffice-java-common
 libreoffice-script-provider-python
 libreoffice-sdbc-firebird
 libreoffice-wiki-publisher
 libreoffice-base-core
 libreoffice-sdbc-hsqldb
E: Sub-process /usr/bin/dpkg returned an error code (1)
2
  • Which distro and version of Linux are you using?
    – user68186
    Commented Jun 12 at 14:04
  • The key problem is right there in your output: installed libreoffice-common package post-installation script subprocess returned error exit status 10. Your next step is to search that script to determine what exit status 10 means.
    – user535733
    Commented Jun 12 at 14:38

1 Answer 1

0

Try the following:

Open a terminal. Run the following commands.

sudo apt remove --purge libreoffice*
cd ~/Downloads
wget https://ftp.nluug.nl/office/libreoffice/libreoffice/stable/24.2.3/deb/x86_64/LibreOffice_24.2.3_Linux_x86-64_deb.tar.gz
wget https://ftp.nluug.nl/office/libreoffice/libreoffice/stable/24.2.3/deb/x86_64/LibreOffice_24.2.3_Linux_x86-64_deb_helppack_en-US.tar.gz
for x in *.tar.gz; do tar xfv $x; done
sudo dpkg -i LibreOffice_*/DEBS/*.deb
4
  • that actually worked, thanks! Commented Jun 12 at 19:50
  • wait, i have question, how to install language packs? Commented Jun 13 at 20:56
  • nvm i did it by replacing the links to a langpack and an another helppack Commented Jun 13 at 21:01
  • To install both the latest stable version (trial versions are not recommended), its aids and languages, it is convenient to visit: ftp.nluug.nl/office/libreoffice/libreoffice/stable, copy the links to the packages and replace those in the post. Before installing a different version, not an upgrade, for example from 24.2 to 24.8, it is necessary to uninstall the previous version with the commands: sudo apt remove --purge libreoffice* sudo apt remove --purge libobasis*
    – kyodake
    Commented Jun 13 at 22:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .