I have an iPad and a desktop running Ubuntu 12.04 with lots of movie files of various formats (avi, mp4, m4v, etc).

Is it possible to transfer those files from within linux directly to the iPad (without using iTunes to sync) over USB and then play those movies on the iPad without reformatting/resizing all of them?

I've used iTunes in a Windows XP virtualbox instance with other iOS mobile devices before but I would prefer a pure linux approach if possible.

(I'm creating this question so that I can share the solution I found because I failed to find a simple, satisfactory answer elsewhere).


Yes, you can easily copy movies to an iPad (or other iOS device) in Ubuntu without using iTunes or Wifi or Dropbox or any of the other terrible solutions out there.

First, simply choose one of the many video player apps available from within the App Store. (Searching for video player returns many irrelevant results, I recommend searching for avi player or mp4 player or whatever your desired format is). I found flex:player and that has worked for my needs and is free but has pretty much no features beyond video playback. Other players provide more features but can cost between $0.99 and $4.99 generally.

Second, plug your iPad into your computer via USB. You should hopefully get a popup showing two mount points for your iPad.

  • My iPad (or whatever your iPad's name is)
  • Documents on My iPad

I believe this functionality goes as far back as 11.04 but at least back to 11.10. See troubleshooting below if this does not happen.

Navigate to 'Documents on My iPad' (again, your name will vary) and find the application you just installed. It will look like an application with an icon but it is actually a folder for that app and its files (the user accessible ones at least).

Example of 'Documents on My iPad' mount

Open that folder (i.e. double click on it) and then open the Documents folder within.

Now all you have to do is copy your video files into this folder. When you next open your chosen video player, all of your movies should be visible and available for playback (assuming the video player supports your codecs, if it doesn't, another one probably does).

Note: I've generally found that if I load new video files onto the device while the app is open, I have to close and re-open the app for it to register the new files. However, some apps may be more proactive in scanning for new files.


If your device is not automatically paired and mounted:

Make sure you have libimobiledevice-utils and ifuse installed

sudo apt-get install libimobiledevice-utils ifuse

and then run

idevicepair unpair && idevicepair pair

and then disconnect and reconnect your device.

If you do not see video files you have copied

  • Make sure you copied the files to the correct app's individual Documents folder.
  • Close and reopen the app to get it to refresh its file list.
  • Read the app's documentation to ensure that the app you chose supports the video format and codec in question.

A file is visible but does not play properly/at all

  • Read the app's documentation to ensure that the app you chose supports the video format and codec in question.
  • If your video file is high resolution (such as 1080p), try a lower resolution file. Some apps appear to have problems playing high definition video. The older generation devices also sometimes have trouble because of their slower hardware. You may be stuck downconverting to something more like 720p. (But try a couple different apps first).
  • 2
    This worked great on my ipad 3 with ios 7, but after upgrading to io7, the device asks me if I trust the computer when I connect it via usb. No matter how many times I press the trust button, it asks me again and again if I trust the computer. – Rafi Kamal Oct 1 '13 at 7:17
  • Rafi: If worked great with iOS 7, but after upgrading to 7 it fails? – K7AAY Mar 25 '14 at 8:00
  • 4
    ios8 and Ubuntu 14.04 (with up-to-date packages for libimobiledevice-utils and ifuse as of 2014-12-20) does not work. It shows "iPad", but not the "Documents on My iPad" link. The only thing I've managed to get to work is to pull-in files over scp and wifi, as shown in this answer: askubuntu.com/a/533366/93794 – Darren Cook Dec 20 '14 at 9:01
  • 2
    I wish this worked :( I have Ubuntu 18.10 and iOS 11. When I click on "Documents on My Ipad" I get an error "Unable to access Documents on My iPad / unhandled lockdown error (-2)" – Seub Dec 1 '18 at 18:22

For Ubuntu 14.04 - iOS 8
Rob Van Dam's answer did not work for me.

Download a file manager app from the App Store with sharing functionality, for example:

  • Filemanager App has wifi web server functionality
  • FileBrowser App handles the SMB protocol

you can upload and download your files that way.

  • 1
    Welcome! If this gets upvoted, it will go up in the list, so "above" makes no longer sense; Could you edit to replace it with something like "The answers using..."? – Volker Siegel Oct 7 '14 at 23:11
  • 1
    I installed "Documents 5" by Readdle, which is free, with only non-essential pin-app purchases. I could then tap Network, then SFTP server, and connect to my Ubuntu 14.04 machine that way. (I didn't need to set up an SFTP server - running sshd seemed to enough.) Lots of other connection options. I have tested mp4 and pdf files. The movie player is okay, and the PDF viewer is okay; shame I cannot choose to open the files with alternative movie players, though. – Darren Cook Dec 20 '14 at 9:10
  • 1
    VLC for iOS works well for this. It allows you to simply drag and drop files over WiFi, or pull them from Dropbox. – AdrianoFerrari Nov 23 '15 at 15:05
  • Thanks, VLC for iOS in combination with a local hotspot works really well! :) See ubuntuhandbook.org/index.php/2016/04/… for how to open up a local hotspot – S0me0ne Dec 23 '17 at 14:38

If you do not see your application when navigating in your "Documents on My iPad" folder, you may need to show the hidden files CTRL-H.


first time posting an answer here. apologies if i broke a site rule or something.

if you don't have wifi at home or if you're not interested in spending $4.99 for an ipad app(when this was written), don't bother reading further.

i have a solution, but it requires a local wifi network(not usb) and buying an app at the appstore.

the solution is to set your ubuntu machine as a server and connect to it with your ipad by ftp, allowing transfer of files to and from.

i just made it work in under 5 minutes with my ubuntu13.10/ipad and less than 1 year experience with linux.

  1. go to the appstore from your ipad and install goodreader for ipad. this is the part and the only part where it costs $.

  2. on your ubuntu install vsftpd from Ubuntu Software Center or in terminal run

    sudo apt-get install vsftpd
  3. start vsftpd by running

    sudo /etc/init.d/vsftpd


    service vsftpd start
  4. you should be able to find the inet address by running

    sudo ifconfig
  5. with the inet address, your username, and your password, you can connect to your ubuntu machine from your ipad and download videos or any file by following these simple goodreader instructions.

  6. to watch your video or open whatever file you downloaded, use the browser provided in the goodreader app.

i'm just writing here what worked for me. if you have a better/cheaper way, post it here!

Not the answer you're looking for? Browse other questions tagged or ask your own question.