I was installing [HTK speech recognition kit][2] from source. When I gave make all it is giving following error:

(cd HTKLib && make HTKLib.a) \
      || case "" in *k*) fail=yes;; *) exit 1;; esac;
make[1]: Entering directory `/home/krishna/htk/HTKLib'
gcc  -ansi -D_SVID_SOURCE -DOSS_AUDIO -D'ARCH="i686"' -Wall -Wno-switch -g -O2 -I. -DPHNALG   -c -o HGraf.o HGraf.c
HGraf.c:73:77: fatal error: X11/Xlib.h: No such file or directory
compilation terminated.
make[1]: *** [HGraf.o] Error 1
make[1]: Leaving directory `/home/krishna/htk/HTKLib'
make: *** [HTKLib/HTKLib.a] Error 1

I searched regarding this error [and found that][3]: I need to install package libX11-devel.

$sudo apt-get install libX11-devel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libX11-devel

But it seems that the package does not exist.

  • 1
    Please paste content of /etc/apt/sources.list – ish Jun 16 '12 at 5:28
  • One: you don't need synaptic for that. USC will work just fine. you may need to click show technical packages or the like on the bottom. And two: you have a problem with sources config. include content of /etc/apt/sources.list to help us assist. – Mahesh Jun 16 '12 at 5:29
  • You dont need synaptic for installing packages in your system, installing it will not solve this issue that you are having trying to install the package. Think one of the answers bellow explains that the package name is libX11-dev, that should be the right path. Removed the synaptic references from your question. – Bruno Pereira May 3 '13 at 6:54

You can install libx11-dev package using the command sudo apt-get install libx11-dev, instead of libx11-devel.


I think that you did not enable your other sources. If you do a search for Synaptic in Ubuntu Software Center and it comes up you will see a message that says "This software is available from universe source and a radio button on the left to "use this source" If you click use this source it will enable it.

The other way to enable sources easily is to open the software center and in the upper menu click edit>software sources it will look like this....


As you can see I have all mine enabled but you will only need to enable universe to get synaptic. After you close the window you will need to run

sudo apt-get update

again to get the new packages or wait for Software Center to update at it's next scheduled time. You can then install Synaptic from the terminal as you tried before or from the Software Center.

As far as needing Synaptic, you can get along without it but I like it especially when I am trying to search for a technical thing that is hidden be default in Software Center and it gives you more information on the packages than Software Center and makes technical things a lot easier to uninstall the software sources easier to edit and can be updated without having to open a separate terminal just to run apt-get update.


Try to install Synaptic from the Ubuntu Software Center instead of using the apt-get - this is how I installed it in version 12.04 with no problem.

However I am on my v10.04 machine right now, so I couldn't tell why the apt-get didn't work for you - I just tried to apt-get on this older machine and it seems to work, so maybe Ubuntu took it out of the apt-get repository in v12, although this seems a bit strange - I would think this is something they would keep in the repo for quite some time, besides since libX11-dev package did the same thing, then I'd say it looks like your repositories list got either partially disabled or corrupted...

BTW, I personally don't consider either Synaptic, the apt-get or the Software Center to be one better than the other - I've seen all of them failing to install something that the other 2 had no problem installing - you just have to try whatever works, or install it from the source if all 3 fail...


You just need to update your apt-get .

sudo apt-get update

This will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.