2

I was trying to install the Krunner plugin "Qalculator Runner" and it asked me to install it manually. And in the READme file, the first step was to cmake . in the main directory. So I installed cmake and after I did it, this is the error I got:

CMake Error at /usr/share/cmake-3.28/Modules/FindKDE4.cmake:61 (message):
  ERROR: Could not find KDE4 kde4-config
Call Stack (most recent call first):
  CMakeLists.txt:19 (find_package)

I searched for solutions on Google, StackExchange, etc. but didn't find any solution that works.

3
  • 1
    KDE4/qt4 has reached end of support for more than 5 years. If that plugin does not support qt5/qt6, use something else. Commented May 29 at 3:44
  • You've not provided any Ubuntu/Kubuntu release details; but KDE is currently at KDE Plasma 5 (not KDE Plasma 4) with movements towards KDE Plasma 6 in the work; what release are you using to expect the deprecated KDE Plasma 4 to be there?
    – guiverc
    Commented May 29 at 3:45
  • discourse.ubuntu.com/t/…
    – guiverc
    Commented May 29 at 4:53

1 Answer 1

4

According to KDE Store, the plugin was last updated 15 years ago.

It was designed to be run on KDE4, whose last release was in 2013, and support for qt4 was removed in 2020.

The current version of KDE Plasma is 6 (and latest Kubuntu LTS hosts 5.27).

You will not be able to run this software in any recent versions of Ubuntu. You will have to find some alternative plugin.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .