My microphones don't work anymore after upgrading to 24.04 on a Lenovo Yoga 730-13IWL laptop.

I tried Ubuntu default kernel 6.8.0 and 6.9.1 from Ubuntu mainline kernel installer app.

On Fedora 40 it's all working well, so it should not be a hardware problem.

I tried integrated mic, cable headphones with mic, bluetooth headphones with mic (huawei freebuds 5i), but I had no luck.

I need guidance to dig into logs and pipewire configuration.

~$ inxi -A
  Device-1: Intel Cannon Point-LP High
    Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.9.1-060901-generic
    status: kernel-api
  Server-1: PipeWire v: 1.0.5 status: active

~$ LANG=C pactl list sources | grep Mute
    Mute: no
    Mute: no
  • Could you check if the mics are muted? LANG=C pactl list sources | grep Mute should do this for you.
    – emk2203
    Commented May 20 at 9:55
  • @emk2203 added above. Strangely, pulseaudio-utils was not installed, or maybe got removed in the upgrade. pulseaudio package is also not present, thought it would cooperate with pipewire. alsa-base package is installed. Ubuntu first install is maybe 2017, from then on I've always upgraded Commented May 21 at 10:19
  • Try with a live flash media of ubuntu 24.04 and see if this works. You could copy the audio stuff from /etc to your distro if the mics work in the live media. Personally, I would reinstall from scratch. Carrying 7 years of cruft often has these things as side effects.
    – emk2203
    Commented May 21 at 13:36
  • @emk2203 i got news, if i create a new user then that user sees the mic and can use it normally. So the problem is limited to my user. Guess i have to erase any config file related to audio in my ~/home and hope the system recreates default config files for my user Commented May 22 at 13:34
  • Found it (somewhat)! i've just removed all the files from ~/.local/state/wireplumber , namely : default-nodes, default-profile , default-routes , policy-bluetooth, restore-stream. Don't exactly know why, but it worked! Commented May 22 at 14:27

1 Answer 1


For future reference, something got messed up in ~/.local/state/wireplumber so just remove the content there and let the system rebuild its files

  • This worked for me: Acer Nitro 5 - Ubuntu 24.04 Commented Jun 18 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .