2

I have a problem running an old Windows 3.1 era application (OED.EXE) using Wine 9.0-repack-4build3 on a fresh install of Ubuntu 24.04 using Wayland. On starting it up I get the error message

"The program winevdm.exe has encountered a serious problem and needs to close."  

The Program Error Details begin with the familiar

"Unhandled exception: page fault on read acccess to 0x... in 16-bit code".

However, on Ubuntu 23.10 and Wine 9.0.0.0-mantic1 (WineHQ stable) the program runs correctly. Any suggestions on what to try? I've created a 32 bit prefix and used winecfg to set the version of Windows to be Win 3.1. Other programs work with WINE including a circa 2005 Adobe Acrobat Pro.

Before installing WINE on my primary machine I had done a bit of fiddling, including adding and configuring some gnome shell extensions, and had installed a good bit of software including SageMath 10.3 with its massive dependency requirements. To try and isolate the cause of the problem I've created a VirtualBox VM for 24.04 with just synaptic, gedit and wine installed and then tried installing the OED.

It is running fine in the VM. Before I start flailing about installing all the stuff I have on my primary 24.04 machine, does anyone have any experience with WINE and 24.04 that might point me toward what to try first to see what causes WINE to no longer run that one particular program? I have noticed some of the extensions (especially Desktop Icons NG) have some problems as well as other quirks instroduced with Gnome 46 and 24.04 (e.g., thumbnails aren't shown for files on the Desktop, running VirtualBox VM's are represented by a generic icon in the Dash, the file rename dialog crashes when using the left or right arrows on the inverted T on a standard keyboard for files on the Desktop, tho' it behaves normally in a Files window, the DMZ cursor themes show boxes when the cursor is over the Dash or Top Panel).

3
  • 1
    Check with https://www.winehq.org. Not all Windows programs are available through wine. This is not a Ubuntu problem, this is a wine problem.
    – waltinator
    Commented May 12 at 1:05
  • 1
    if you want it to run native is always better: use dual boot or use virtualbox/vmware and windows in that and then run the program.
    – Rinzwind
    Commented May 12 at 1:09
  • I have cross posted to WineHQ forums. I do have the OED running without problem in a WindowsXP VM as well as the two Ubuntu VMs I'm using for testing, but it's convenience I'm looking for. A quick look for something is more likely if the OED can be run easily (and quickly) from an icon on the Dash rather than having all the overhead of loading a VM and then the app in the VM. Commented May 12 at 17:21

1 Answer 1

1

I finally got wine working, running an old application from the days of XP.
I can't say for sure it will work for every situation. Here's what I did:

  • Installed wine (apt-get install wine)
  • Installed playonlinux (apt-get installed)
  • found some online instructions for installing on 24.04
  • checked for 32 bit architecture with dpkg --print-architecture - didn't have it so -
  • performed sudo dpkg --add-architecture i386
  • downloaded and added the WineHQ repository key as follows:
    sudo mkdir -pm755 /etc/apt/keyrings
    sudo wget -O /etc/apt/keyrings/winehq-archive.key https://dl.winehq.org/wine-builds/winehq.key
  • Download the WineHQ sources file
    sudo wget -NP /etc/apt/sources.list.d/ https://dl.winehq.org/wine-builds/ubuntu/dists/noble/winehq-noble.sources
  • Install Wine (this did not work)
    sudo apt install --install-recommends winehq-stable

NOW at this point, wine was not working. I went back over my notes then decided to use a part of the process from prior to 22.04. That made it work. I mention the 24.04 specific steps above because it is possible that the above combination made my eventual success possible.

  • wget https://dl.winehq.org/wine-builds/Release.key
  • sudo apt-key add Release.key
  • sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/'
  • I then tried something - wine explorer (I thing) which resulted in an error with a hint that I needed to install wine32:i386
  • I then did the following (which brought in a whole lot of packages)
    sudo apt-get install wine32:i386
  • I ran winecfg (I think that's what wine configuration is) and set my environment for XP

After this I can run my old XP program. A very simple old DOS program that done nothing, iefbr14.com, now fails for lack of another package so - another step:

  • sudo apt install dosbox
1
  • Alas, this is where I am now. I can run the WINE installed accessories---iexplore.exe, wordpad.exe---and other apps---Adobe Acrobat Pro, Designer, et al---but not my OED.EXE. I think my next test will be to look for another early 90s app to try, but that means rummaging around the back of my garage and I'm not up to that right now. If anyone knows where some of those are archived I will take a look. Commented May 14 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .