I am using Ubuntu 12.04, unity. If I boot regularly, there is no internet access. There is no network icon in the unity panel nor does the "network connections" program show anything. However, if I boot into recovery mode and select "enable networking," everything works as usual.

As far as I know, I have not messed with my network configurations for several months prior to this problem.

  • How are you connected to your router? LAN / W-LAN or something else like D-LAN?
    – jplatte
    Jun 16, 2012 at 13:06
  • It is, indeed W-LAN
    – Azmisov
    Jun 21, 2012 at 23:09

2 Answers 2


I have exactly the same problem. I have a Dell Precision T7500 pretty much out-of-the box, with a Quadro FX 580 and a pair of 1T drives. At one point I was dual booting Win 7 and Ubuntu 11.10 with no problems. Then I upgraded to 12.04, and problems made the system unusable. I had modules crashing with the appropriate dialog boxes, when I rebooted, I would get stuck at a command line login -- which didn't work. Eventually I gave up, wiped out the partition and reinstalled 12.04. After the normal problems trying to get my video card to work I realized that the system acted the same way it had before. I.e., very slow, processes crashing; unusable. I finally got what appeared to be a usable system by wiping out the partition, doing a fresh install, and going in to recovery mode on the first boot. From there I ran fsck, started the network, and installed nvidia-current and did an update/upgrade -- which was extensive. But the system seemed normal when it came up. I installed and configured autofs and all was well. Until I rebooted, then I was back to the same problem. I found that all I had to do was boot to recovery mode, start networking, then resume boot and all was well. I tried booting without going through recovery mode and waiting several minutes (like 15-20 or more) to get a usable login prompt, but could only log in as a local user. I did a sudo -i and ran initctl list and found that many of the processes were still waiting. I also had no IPv4 address, though I did have a pair of legal global IPv6 addresses. I ran dhclient -- which took a very long time to run, and had another probably unrelated process die in the interim -- and got an IPv4 address and the correct /etc/resolv.conf. Syslog shows that many of the processes started by dbus failed to activate.

A Google search shows that this problem is not unique to Ubuntu, but also affects at least Red Hat and Debian, and has been for a year or more. Clearly the upstart/dbus mechanism is not quite ready for prime time.


Okay. So, I checked the /etc/network/interfaces file and apparently, all the newline characters had been replaced with the letter "n". Changing them back to newline characters solved the problem for me.

If this doesn't help you, you might find these links useful:

And here's the /etc/network/interfaces file:

auto lo
iface lo inet loopback
  • can you post your /etc/network/interfaces file please ? or at least tell the methodology you used ? I'm running into the same problem and can't fix it. Thanks
    – user72893
    Jun 24, 2012 at 7:24
  • I edited my answer. Hope that fixes it for you.
    – Azmisov
    Jun 25, 2012 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.