1

I have just clean installed Lubuntu 24.04LTS from Lubuntu dowloads to my HP 255 G1 laptop. I can not access my external hard drive now.

Error mounting /dev/sdb1 at/media/name/Transcend:wrong fs type,bad option,bad superblock on /dev/sdb1,missing codepage or helper program,or other error.

I can access the drive with other laptop. Drive is NTFS, please help.

7
  • 1
    Was the disk in question last used on a Windows system with the "Fast boot" setting enabled? The Windows "Fast Boot" (Windows defaults to "ON") setting leaves the disk partition in an undocumented, proprietary state that Linux isn't permitted to recognize. Boot back into Windows and disable "Fast Boot". Be prepared to have to re-disable "Fast Boot" - Windows updates have been known to turn it back on. See windowscentral.com/how-disable-windows-10-fast-startup
    – waltinator
    Commented May 3 at 16:00
  • No, I backed up all my data to the drive before installing Lubuntu 24.04LTS with the intention of reinstalling my data afterwards, unfortunately I can't do that because of the error as I have described. Should I try sudo ntfsfix -b /dev/sdb1 or could this damage my data?
    – Marty
    Commented May 3 at 16:23
  • As NTFS is a windows file-system, I'd perform checks and apply fixes on windows. Does the drive work correctly on other windows machines? as windows fastboot/hibernate etc. unclean drives can be used normally on the windows system that left the file-system unclean, but you'll have problems on other machines (regardless of OS where file-system is unclean). Providing command you used & full output of what you see maybe helpful (or if you use GUI tools, what you did maybe inc. tool used). Message implies unclean fs OR incorrect mount command to me.
    – guiverc
    Commented May 4 at 1:54
  • Yes the drive works on a windows 11 laptop. I connected the drive to a usb port & the error message comes up. In (disks) the drive is shown but I get the same error when I select mount.
    – Marty
    Commented May 4 at 8:46
  • I am facing similar issue since i installed Kubuntu 24.04 Commented May 4 at 21:34

3 Answers 3

1

To fix the disk run on Windows chkdsk /f D:. Change the drive letter with the letter the disk is named on Windows.
This should fix the issue.

Not required: I also noticed that "mount" can mount the disk anyway: Try to do lsblk to get the disk path. Make a temp directory before and change /dev/sda2 with the path to the disk. And then:

sudo mount /dev/sda2 ~/temp
3
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented May 10 at 6:20
  • I have error mounting /dev/sdb1 So why would I try sudo mount /dev/sda2 ~/temp? Where should I create the temp directory and what is it for? On Windows what should I change the disk letter to?
    – Marty
    Commented May 10 at 9:48
  • to fix the issue in any case go on windows check the letter associated to the disk you want to check (e.g. for my case the disk was in D:) and run the command chkdsk /f D: (replace D with the letter of where is the disk on windows). I just noticed that sometimes "mount" works anyway from command line, but this is less important. just fix the disk from windows and everything should work
    – Davide
    Commented May 11 at 21:46
0

Occasionally, I'm facing the same issue with Ubuntu 24.04. The following steps helped me:

  1. Run Disks app.
  2. Select problematic disk.
  3. Click the cog wheel.
  4. Edit Mount Options….
  5. Turn off User Session Defaults.
  6. Change other parameters as required.
0

Turn off User Session Defaults. That is just one step and it worked for me immediately. Thank you very much "eniac"

1)Run Disks app. 2)Select problematic disk. 3) Click the cog wheel. (like "setting icon" in Disk app - Additional Partition Option) 4) Choose Edit Mount Options…. (just click on the First Top Line "choice" to Turn off "User Session Defaults"

Dear "eniac" Thank you very much Sorry to post here since I am not allowed to comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .