I have Ubuntu and GNOME 3 and when I do Alt+Left-click it grabs the current window. How do I stop this from happening, as I need this shortcut in Blender which I update often so changing it inside Blender is not logical.

In your Compiz Config Settings Manager click on "Move Window" plugin. Click on the very first mouse shortcut (it should be <ALT>Button1) and Disable it.

  • I have tried this but every time it it dont work, if i reopen Compiz Config Settings Manager its reverted back to alt+button1 – Steven Jun 15 '12 at 13:41
  • What if you try to delete the value in gconf-editor? Key is stored in /apps/compiz-1/plugins/move/screen0/options – jasmines Jun 15 '12 at 14:11
  • never mind i fixed in the thge keyboard layout app, changed the setting under the layouts tab to the second option and it seems to have fixed my issue. – Steven Jun 15 '12 at 14:24

If CompizConfig doesnt work for you, try this:

Fix using dconf Editor

Install dconf Editor:

sudo apt-get install dconf-editor

Search for dconf Editor in dash and run it, then search for mouse-button-modifier and change the key from <Alt> to <Super> or anything else. That worked for me.

Try using Xubuntu instead. I struggled a bunch with this, and was pointed toward Xubuntu because its interface steals from apps less, and is more customizable.

  • 2
    The question is about GNOME. An answer about switching desktop environments is an bit out of scope I think. – gertvdijk Oct 12 '13 at 20:36

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.