I upgraded Ubuntu to 12.04 from 11.10. The printer works, but the scanner doesn't now. In 11.10 I had to install a special driver from Brother. The printer's model is Brother MFC-290C. The computer is a Toshiba Satellite. How can I get the scanner working?


I have a 64-bit installation on the Toshiba Satellite. Thank you for your instructions, Chad--24216. I followed each step: 1 through 5. I also updated the Brother Linux scanner S-KEY tool.

The output of dpkg -l | grep Brother is:

ii  brscan-skey                            0.2.3-0                                 Brother Linux scanner S-KEY tool
ii  brscan3                                0.2.11-5                                
Brother Scanner Driver
ii  mfc290ccupswrapper:i386                1.1.2-2                                 Brother CUPS Inkjet Printer Definitions
ii  mfc290clpr:i386                        1.1.2-2                                 Brother lpr Inkjet Printer Definitions
ii  printer-driver-ptouch                  1.3-3ubuntu0.1                          printer driver Brother P-touch label printers    

Still the scanner does not work. Here is the message from Xsane:

Failed to open device brother3:bus6;dev1:  Invalid argument.  

Here is the message from Simple Scan:

Failed to scan. Unable to connect to scanner.  

And Scan Utility still doesn't display the scanner line.

  • Did you try this: askubuntu.com/a/143421/3940? – Takkat Jun 15 '12 at 10:53
  • Lorenzo, make sure that you have "sane-utils" installed on your system (sudo apt-get install sane-utils). Also, I did not install the scan-key-tool on my box. I do not recommend installing this s-key tool. Although I cannot say if this key-tool is what's causing the problem. If I was you, I would back up everything in my HOME folder, do a fresh install of 12.04 and then follow my instructions. and don't install the s-key tool. – Chad--24216 Jun 19 '12 at 18:02

Unfortunately none of the solutions above worked for my Brother DCP-7045N, but just the normal standard installation:

Download packages from http://solutions.brother.com/

Install doing
sudo dpkg -i --force-all brscan3-0.2.5-2.i386.deb
sudo dpkg -i --force-all brscan-skey-0.2.1-1.i386.deb

Check with dpkg -l | grep Brother

brsaneconfig3 -a name=SCANNER model=DCP-7045N ip=

Check with brsaneconfig3 -q | grep DCP-7045N

I hope it does it for you too!

  • had to add rule in /lib/udev/rules.d/40-libsane.rules : # Brother scanners ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="01fd", MODE="0660", GROUP="scanner", ENV{libsane_matched}="yes" and reboot to make it work without root rights – Philippe Gachoud Jun 15 '14 at 14:40

Follow these steps to get your scanner working.

1) do the following:

-press: Alt+F2

-type this: gksu gedit /lib/udev/rules.d/40-libsane.rules

-add the following lines BEFORE where it says "# The following rule will disable"

    # Brother scanner
    ATTRS {idVendor}=="04f9", ENV {libsane_matched}="yes"

2) go to this website and download the "brscan3 DEB" driver to your Desktop. Pick the 32-bit version if you installed 32-bit Ubuntu. Pick the 64-bit version if you installed 64-bit Ubuntu: Brother Brscan3 driver

3) open Terminal and change to the Desktop directory (where your download is)

cd ~/Desktop

4) install the driver

    sudo dpkg -i <name_of_file_that_you_downloaded.deb>

-when installed, the driver should show up in Synaptic like so: brscan3

5) install xsane

sudo apt-get install xsane

Everything should work now. Open "XSane" to accomplish scans.


You could try to download the latest Linux scanner driver packages for the MFC-290C and install them. Moreover, check the installation instructions provided by Brother.


My solution to fix Brother MFC5440CN, scanner only working using sudo xsane:

I had already created an additional User account but that did not sort the problem. Here's my fix. (Ubuntu 12.04, 32 bit). Follow the advice regarding the insertion of the script as instructed by Chad (& others). The editor opens a copy of the file. Close this and work on your original. Copy and paste this in at the location specified.

# Brother scanner
ATTRS {idVendor}=="04f9", ENV {libsane_matched}="yes"

Make sure to do a carriage return and leave a blank row beneath it.

Do not alter anything else. Save the file. The insertion of the carriage return sorted my problem. I hope it works for you. I nearly tore my hair out trying to sort this so I know how frustrating it can be. Good Luck.


A very simple solution is:

  1. Go to Ubuntu Software center.
  2. Search for HPLIP Toolbox.
  3. Install HPLIP.
  4. Open HPLIP and wait for some time. Automatically under "Actions", various options will appear such as- Print, Scan, Print Test Page.
  5. Click on Scan- If the driver is missing, it will automatically ask you for installing drivers.
  6. Go alongwith the prompt and it will install whatever it needs to install.
  7. Enjoy scanning.
  • The question is about a Brother Scanner, not an HP. – virtualxtc Dec 17 '13 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.