This question already has an answer here:

Yesterday I installed Ubuntu 12.04 for the first time (I've always been a Windows user) as I was at the office and I had the Ethernet connected.

At home I only use WI-FI. When I started Ubuntu it didn't connect or try to connect with any network.

By google, I found the command rfkill and these are the results:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

2: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes

3: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

Well, the WI-FI is blocked by hardware, so I tried the command rfkill unblock 2 and it didn't work. As I didn't know even my Broadcom model, I found lspci and the result for the WI-FI is:

0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

My laptop is a Dell Vostro 1520 with WinXP also installed. Thanks for the help!

PS: It also may help that when I enter System Settings > Network (it may be different, my Ubuntu is in Spanish) "Airplane Mode" is connected. When I try to unlock it, it goes to its original place after I close that window and open it again and when I reboot.

Update added from comment to an answer

The Broadcom "Additional Drivers" are turned on and enabled.

marked as duplicate by Fabby, Pilot6, Charles Green, Ravan, Eric Carvalho Dec 18 '15 at 23:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Broadcom and ubuntu do not play nicely together

Try these fixes

Installing Broadcom Wireless Drivers

  • OMG that's speed. Thanks, it DID work! – Fernando Jun 15 '12 at 6:35
  • any time I reboot my computer it doesn't work again and I have to launch the commands again. Is there any mode to fix this? – Fernando Jun 15 '12 at 9:14
  • Run as script at start up in rc.local? – fleamour Feb 15 '14 at 15:29

After trying several things, I solved it by reseting the BIOS (Lenovo B570).

When you turn on the computer, press F2 to enter the BIOS, then reset it F9 .

  • I confirm, resetting BIOS solves the problem (Lenovo E430c, Ubuntu 13.10). The keys for entering BIOS may be different. – Taha Jahangir Apr 21 '14 at 6:01

I found this and it worked for me.

This is how to get the wireless hardswitch to turn on using the terminal:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer
sudo apt-get install b43-fwcutter

Then enter this command to turn it on:

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl| lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3 |rt6|rt7|witch|wl'

Reboot and see if it stays on.

  • 3
    The cat ... | egrep ... command just outputs information, it does not actually change anything. (See man cat and man egrep.) – Eliah Kagan Jul 5 '12 at 10:15
  • fails with 14.94 – K7AAY May 23 '14 at 17:39

First of all: I'm in a HP Pavilion dv4-1528la, running Ubuntu 12.04 LTS

Well, I must say within last 4 hours I've been trying every possible solution I found in any ubuntu forum. And I finally made it, found the solution shared in a spanish forum. I hope is not too late to help someone to find its way.

So, after trying any possible combination with rfkill in terminal, with and w/o sudo, trying to delete some config files I've found in other "possible answers", and searching into BIOS setup the option I didn't find about turning on Wireless always on startup, I kept digging and the answer I found was this:

Due to an error in linux kernel, rfkill sometimes doesn't act as expected, and there is some incompatibility within linux hardware controller and some hardware devices. Solution recommended by this guy is to start laptop with a bootable pendrive and start wireless from there.

So that's what I did, fortunately I had the pendrive wich I used to install current Ubuntu 12.04 LTS OS I'm in now, and after booting with it, I was able to start wireless directly from the menu bar icon. Then it's just a matter of turning off, remove pendrive, and turn on again from HDD. And it's working again, no hard-block anymore.

enter image description here

Pd: I'm just guessing, but I think what triggered the issue in first place is that I turned off the laptop with Wireless deactivated, and then after turning it on again, there was no way to unblock wifi hardware from being off, or not at least with my touch hardware switch.


I just had to push the wireless switch on the side of my laptop some how I accidentally had turned it off. But now its working, gotta watch out for that small mistake. Costs me 2 hours of searching.


Broadcom hardware often requires closed-source drivers. Have you enabled Proprietary Drivers? To do this go to System Settings -> Additional Drivers

Are you sure the hardware switch for Wi-Fi on your PC is turned on?

  • It's turned on indeed and the driver are enabled. – Fernando Jun 15 '12 at 6:24
echo "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus.conf

This solution solved the problem in an Asus X552C with a Broadcom 43225 wifi card

  • 1
    OP does not have ASUS. – Pilot6 Dec 16 '15 at 14:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.