While this is very similar to other problems reported (and even abandoned and closed), I haven't seen so far any suggestion that solves the issue. On the other hand, there seem to be some details differing from other cases reported.

My Ubuntu 10.04 boots and runs up to showing the background, drumbeat sound, and mouse pointer but not login window.

I can change to tty1 (or any or the other five), and have tried stopping, reconfiguring and restarting gdm; tried reconfiguring plymouth; asked for apt-get to fix any broken packages (none), even reconfigured and updated grub (not really necessary).

What I managed to do is to run startx after

sudo service gdm stop

Compiz working fine there, I know all my files are OK. But no gnome or anything except my desktop background image and a terminal if I do [Ctrl]+[Alt]+[T] (This one might dissapear after a while, though).

I suspect some (gdm) configuration file has been corrupted, but I have no idea which it might be or how to restore it.

I have some log files in case somebody could look at them and help. Thank you in advance.

1 Answer 1


Faced with the perspective of having to work on Windows 7 (same computer, almost never-used option of dual boot), and disliking it in general, I tried upgrading to Ubuntu 12.04. Didn't work. For some reason, I suspect it has to be done under a graphical environment.

So I insisted, got myself a LiveCD and upgraded from it. It did just fine and now I have a working 12.04.

Not an answer to my original problem, yet it can be considered a solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.