0

When I open a file in gedit and there is another gedit window opened, then the file is opened in a new tab in the already existing gedit instance instead of in a new gedit window. This can be very annoying, especially if the gedit window is on another desktop.

How can I set gedit to always open new files in new windows?

I am using Xubuntu 22.04 and the answers I've found about this issue are for older versions and do not work with my version.

1 Answer 1

1

Customize the .desktop launcher for Gedit by settings:

  • Set DBusActivatable= to false such that dbus is not used to communicate with the application
  • Add the --new-window option to the Exec= line so it looks like Exec=gedit --new-window %U.

The .desktop launcher is found under /usr/share/applications. On my system, it is called /usr/share/applications/org.gnome.gedit.desktop. Copy that file to your ~/.local/share/applications folder, and make the changes indicated above to that copy. That copy will override the system-installed file. Note also that there is no need to be root to perform this customization.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .