I'm fighting with Evolution. Basically it's working fine -- but it is very slow to react in certain situations.

Helper questions

  1. Could it be that changing away from Bonobo has to do with slowing-down?

  2. There might be some trouble with the new engine and "asynchronous actions". What to do about it? Are there e.g. any configuration files?

  3. I want to get the previous "working mood" back. How can I speed this thing up?

Different scenarios

  • when sending a mail, the composer window hangs there inactive for a couple of seconds, everything grayed out (the bigger the message/attachments, the longer it takes). Though there is a green check mark saying it's sent, I'm not sure a) why it's still blocking everything and b) whether I could simply close it without "breaking"/"losing" anything. In earlier versions, the composer window was closing pretty fast, and one could see the message being stored into the local "outbox" until it was sent, and one could immediately continue with the next task. I prefer that behaviour over the current, where I cannot do anything in the application until the window closes.
  • switching between modules. Coming from mail and switching to the address book takes a couple of seconds. Same for switching to the calendar. I read about different "possible causes" and tried a few things:
    • I only have 3 local address books, so no networking should be involved here. To make sure, I switched to offline mode and then tried to access the address book. No noticeable difference.
    • I use 3 Google Calendars. Switching to offline mode made a minor difference, but so minor that it also could be "imagination" since one might have expected this in this case
    • according to some reports, disabling the tasks should help. Well, it didn't in my case, as I don't use them regularly (just two local items stored here)

Maybe I should also mention that I'm using the KDE4 desktop (so no Unity or Gnome, though both is installed on the computer). And I did not have this issue before I updated to 12.04.

  • Just wondering: nobody else experiencing this? Or experienced it, and has it solved? – Izzy Jul 5 '12 at 15:51
  • ...related Android-biased -thread here and Debian-biased -thread here. I love pioneer threads +1! I may have similar problem with iOS calendar here -- investigating... – hhh Sep 10 '12 at 21:33
  • @hhh I can find my sent mails fine, so the problems are not really related. It just takes far to long to get them sent: After hitting the "Send" button, even a small mail (less than 5kB) keeps the composer window open for 10+ seconds -- while I cannot do anything else in Evolution. With previous versions, the window closed immediately, with the mail being queued in the local "Outbox" -- and I could continue working with the application. Same delay when switching between the modules. I'd even be happy if I could get some hints on how to debug this... – Izzy Sep 10 '12 at 21:38
  • Though I'm not sure whether it is IMAP related, your version seems better readable -- and yes, looks like we are on the same wavelength ;) I'm pretty sure it has to do with moving away from Bonobo (as other sources on the net suggest). But only 60 visits within 2 months make me think not too many others experience this problem. I checked all config options available from within Evolution, but was unable to find anything helpful. – Izzy Sep 10 '12 at 21:51
  • Possible bug here (some odd hold-on-laggy -thing with Inbox in Evolution)? I try to break all problems into parts, solving small puzzles at a time :D – hhh Sep 10 '12 at 21:54

While I did it for different reasons, it may help to upgrade to Evolution 3.4. Ubuntu intentionally remained on an older version of Evolution (and some other Gnome applications) for 12.04, due to insufficient testing. That said, I haven't had any of the issues you're describing.

Thanks to a helpful fellow AU member, I found the Stracciatella PPA, which has all the Gnome 3.4 stuff. Installing Evolution itself was pretty painless, though Ubuntu really doesn't want you to, so you have to tell it to do so explicitly.

  1. Add the repo: sudo apt-add-repository ppa:janvitus/gnomestracciatella
  2. Update apt (sudo apt-get update)
  3. Install Evolution (sudo apt-get install evolution)
  4. Remove or disable the PPA, so Ubuntu doesn't continue to complain that it can't update everything.
  • Thanks a lot, Shauna! I will give this a try. The "update complaints" you are speaking about are probably dependency issues coming up on each and every apt-get upgrade, or are you speaking about something different? – Izzy Oct 9 '12 at 14:51
  • @Izzy - I'm talking different complaints. Ubuntu actively holds back upgrading the Gnome 3.4 applications that it hasn't already approved (this is why you have to explicitly install Evolution, instead of just doing apt-get upgrade). If you keep the PPA in, the update manager will repeatedly complain that it can't do a full update and will ask about doing a "partial upgrade." – Shauna Oct 9 '12 at 17:07
  • Thanks for the update! So I will remove/disable that repo afterwards. – Izzy Oct 9 '12 at 18:35
  • Wow! Fantastic! Worked like a charm!! Just started the new version, and for a test opened a message window with "message source", then closed it -- jikes, gone as soon as I clicked! Give me two more days to check for long-time run (see my update on the other answer, last time it slowed down again after running a couple of hours). My +1 you already got -- looks like accept and bounty follow soon! Thanks again! – Izzy Oct 10 '12 at 18:32
  • Bad news: I already had to kill Evolution 3 or 4 times now as it was just hung and allowed no input whatsoever. Are you sure there are no other dependent libraries which need to be updated? At the last hung I checked with strace, and the evolution process was frozen with FUTEX_WAIT_PRIVATE (not sure what it waited for). – Izzy Oct 10 '12 at 20:50

After doing some more Google-Fu I found a similar looking problem for an (even) older version of Evolution, where a "buggy" plugin was causing the trouble. Not having that particular plugin enabled or even installed, I went over the ones which were enabled. Everything being clearly not needed in my case, I disabled:

  • dbx-import (MS Outlook stuff -- I never needed)
  • pst-import (again MS Outlook)
  • face (I prefer plain-text mails either, so no need to attach my face)
  • auto-contacts (everytime you answer a mail, the recipient gets added to your address book -- I never needed that)
  • email-custom-header (nice stuff to play with, adding custom headers to all mails you send -- but certainly not essential)
  • mark-all-read (rarely used this)

Looks like I managed to improve the situation a lot: Switching between components got much faster (instead of 5-10s, it now takes less than 1s), the composer window now closes within ~2s (instead of 10+ seconds).

So things are almost back to normal. Still doesn't feel that smooth as before the update to 12.04 (especially the composer window "hanging around") -- but that might as well be imagination. The small delay now left is something I can really live with -- as opposed to the laggy behaviour before.

I still might narrow down the responsible plugins when I feel the need for one of them (which might only happen with the last two), in which case I will update my answer here. But for now I'm happy things got so much smother -- and don't want to "touch the running system" at the moment :)

EDIT: This seemed to only have brought a temporary improvement. After Evolution has been running for several hours, it slows down again. Not so much in component switching -- but the composer window still stays open until the message has been completely sent, which is especially annoying with large messages having e.g. large attachments. So I'm still looking for a solution on this -- what I have now is, if at all, just a partly work-around at best.


How it magically solved

I had already given up on this, when it suddenly solved itself as side-effect of something else. The culprit once more (and I should already have expected that plus being used to it) seemed to be KDE4's plasma desktop: Having switched to LXDE about a week ago, a lot of things became excitingly snappy (including Firefox and Evolution), a bunch of other problems mysteriously disappeared1,2, and I'm left almost happy with the situation -- except for the mail-window on sending a message, which still does not close immediately as in previous versions (but neither does take that long anymore), and the "switch" introduced a really minor new issue concerning my SuperKaramba status bar.


Being a KDE user for almost 20 years now (yeah, that long, when in the 1990s KDE1 was introduced), I never wanted that plasma-desktop in the first place. So until I had to switch to a new machine last year, I was still using KUbuntu 8.04 as the latest LTE supporting KDE 3.5.*. I didn't want to setup my new machine with an outdated system either, which made me install Ubuntu 12.04 with KDE 4.x (including its plasma-desktop). If you browse my questions (not that many), you will see I immediately had a bunch of problems: plasma ate my memory3, Evolution got slow until being almost unusable if not closed and restarted twice a week (this question here), plus more things I didn't even dare asking1,2. And the hard time getting rid of Nepomuk, Akonadi, and all the other unwanted services I didn't ask for!

So it's a somehow sad thing to break up with KDesktop after almost 20 years -- but it looks like it's time for a change. About 8 days into being a LXDE user, I must say I hardly miss a thing -- except for my SuperKaramba status bar which I configured and adjusted over the last 10 years to exactly fit my needs, and does not behave correctly anymore4.

So to stop my "rant": If you're using a lot of Gnome apps (especially Evolution), KDE4 is no good choice for your desktop environment. If you neither a friend of Unity (and all its background services, like in my case), consider using LXDE, XFCE or E17 (Enlightment) instead -- saves you a lot of headache! You still can use your favorite KDE apps if needed (for me this includes Okular, Gwenview, Qps, K3B, and KTerminal).

And if you didn't see me updating this question/answer within the next 3 months, you can safely assume this answer really solved it. Being cautions, I still will wait a little time before accepting it :)


1 one other problem solved along: when editing a mail, and switching signatur or formatting via the corresponding drop-downs, I was no longer able to write in the editor window. After a few weeks I found a work-around (opening some menu, closing it again, and writing became possible), but it still was annoying

2 using the desktop pager to switch to another desktop took up to a minute, while plasma was completely frozen. Until the switch finally fired, I could still work in apps open on the "old" desktop, though.

3 without showing up such in top, memstat, and other tools -- see Free RAM disappears - Memory leak?

4 see Superkaramba on LXDE ignores theme position and cannot handle lock/unlock?. I tried it with Screenlets (which claims to handle SuperKaramba themes), but all I get to see with it is the background image. It currently displays everything fine using superkaramba from plasma, but all actions are dead.

  • The 3 month period has expired, still everything as presented in this answer: Time to accept it :) – Izzy Sep 22 '13 at 22:28

Sad to see this is still an issue, but... something seems to be working for me now. I'm using Evolution 3.10.4 on an Ubuntu 14.04 install, and I have two google IMAP accounts (and a few other non-google accounts). I was noticing the status bar at the bottom of Evolution would seem to hang on "Resolving imap.google.com", so... I ran a few commands; ping imap.google.com and ping smtp.google.com. I know, less than ideal (google might change the IP, load-balancing, ping it twice and you'll get a different IP!), but I added those two entries to my /etc/hosts file:

74.125.28.### imap.gmail.com 173.194.79.### smtp.gmail.com

(Use IPs from your own ping)

It's only been a day, but I noticed instant improvement. YMMV.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.