1

I'm new to ubuntu and linux in general and I'm trying to install FUSE so I can install .appimage files. But when I try to install or upgrade something using apt or apt-get i get this error: emacs: error while loading shared libraries: libotf.so.1: cannot open shared object file: No such file or directory

Even tho I'm quite new to linux I know what a symlink is and have noticed that both libotf.so.1 and libotf.so.0 are linked to libotf.so wich does not exist.

I got no idea how to fix this so I would greatly appreciate any help!

2
  • 1
    Ask the packaging system which package provides libotf.so with the terminal command dpkg -S libotf.so. Install that package, and its' dependencies.
    – waltinator
    Commented Mar 17 at 4:05
  • @waltinator That probably won't work if you don't have the package installed already. The command you meant to post was apt-file search libotf.so. You could also do a search at packages.ubuntu.com
    – moo
    Commented Mar 17 at 6:34

2 Answers 2

1

Ok, so what I did.

Thanks to @moo for showing me Ubuntu packages I believe I was able to solve this for myself.

Here's what I did:

I went to Ubuntu packages and searched all packages that were missing, and on the site I downloaded liboft1 and libm17n-0 which were missing. And using something like GDebi package installer, I installed them both, which seems to solve the problem..

0

You have probably worked out from the error message that you're missing libotf.so

To find out which package contains libotf.so, you can use the following:

apt-file search libotf.so

or you can search on packages.ubuntu.com

This shows that you need the libotf-dev package. Install with:

sudo apt update && sudo apt install libotf-dev
1
  • Well, I tried it but I can't do sudo apt install libotf-dev because I get the same error emacs: error while loading shared libraries: libotf.so.1.... I've also tried to install the libotf-dev via Ubuntu packages but that didn't do anything Commented Mar 17 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .