5

I recently downloaded an Ubuntu 9.10 virtual appliance for VMWare and want to install a LAMP server on it. Normally, I would just sudo tasksel install lamp-server but that seems to just return without doing anything. So I tried sudo tasksel to bring up the list of packages. But this list only includes three options... Print server, Ubuntu desktop and Manual package selection. I thought maybe it was in Manual package selection but I didn't see it. I'm pretty new to Ubuntu (and linux in general) so I'm not sure where to go next. The only posts I've found about missing options in tasksel says it just suddenly started showing additional options the next day...

Why don't I have all the options I usually do (like LAMP server)? How can I get these options back?

4

I can only imagine that the available package list is either not there or has been corrupted somehow. sudo apt-get update might fix it.

You can actually install tasks through other package managers too. For example, you should be able to load up aptitude and browse and install the available tasks there.

Obviously if you can't see any packages at all (let alone tasks) there is a deeper issue.

  • Thanks Oli... apt-get update solved the issue. I know have all the packages I'd expect in tasksel. I would +1 but only have 6 rep and cant vote yet :( – Chaulky Nov 27 '10 at 2:00
  • @Chaulky I'll survive :) I've got too many points anyway. – Oli Nov 27 '10 at 2:14
  • just hit 18... +1!! :) – Chaulky Nov 27 '10 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.