0

I'm trying to set the backup location for timeshift to a new external hard drive I just bought.
I formatted the drive w/ an ext4 filesystem w/ the command:

    sudo mkfs.ext4 /dev/sde

I then ran the commands:

    sudo mkdir /mnt/backup_hd
    sudo mount /dev/sde /mnt/backup_hd

Then I try to set the timeshift backup location with the command:

    sudo timeshift --snapshot-device /mnt/backup_hd

And I get the error:

    App config loaded: /etc/timeshift/timeshift.json
    E: Device not found: '/mnt/backup_hd'
    App config saved: /etc/timeshift/timeshift.json

What am I doing wrong?

4
  • Did you read the messages for the command you gave, at the sudo mount /dev/sde /mnt/backup_hd I'd have expected error message(s) in that you tried to mount a device (not a partition). Your mkfs.ext4 command will according to the manual "mke2fs is used to create an ext2, ext3, or ext4 file system, usually in a disk partition (or file) named by device" ie. it created a fs on a partition, but you tried to mount the device itself; not what you created. You've not provided any OS/release details; so your system may differ to what I'd expect on my OS/release.
    – guiverc
    Commented Mar 13 at 2:01
  • 1
    The timeshift documentation isn't clear, but it looks like the --snapshot option expects a block device argument, rather than a mountpoint. What happens if you unmount it (sudo umount /dev/sde), then try sudo timeshift --snapshot-device /dev/sde? Commented Mar 13 at 16:49
  • So confused. Based on guiverc's comment, I figured I had made a mistake in formatting using '/dev/sde'. So I ran commands to recreate the partition 'sde1' w/in the 'sde' device. And then mounted 'sde1' as before and re-ran the timeshift commands but got the same error.
    – gboy
    Commented Mar 14 at 2:52
  • But then tried what steeldrive suggested and typed: sudo umount /dev/sde and then ran the command: sudo timeshift --snapshot-device /dev/sde And then did not receive the ' Device not found' error. But with 'sde' not mounted. How can this backup work? I'm clearly not understanding the fundamentals of mounting and how to get timeshift to talk to devices/partitions. What am I missing?
    – gboy
    Commented Mar 14 at 2:56

1 Answer 1

0

@steeldriver had pretty much the right answer. However, it was not necessary for the device to be unmounted. It was just necessary for me to specify a device in the timeshift --snapshot-device command and not a partition. So even with /dev/sde1 mounted, I just had to run:

sudo timeshift --snapshot-device /dev/sde

Then, upon creating my first timeshift backup, the software just creates a folder at the top of the partition named 'timeshift' and stores all backups within. Thanks for the help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .