This is the situation. There are 3 machines in the office. The Operating systems on them are respectively,

  1. Linux mint
  2. Ubuntu 12.04
  3. Windows Vista

The Ubuntu (#2) machine is supposed to be the common file server between the machines #1 and #3.

Machine #2 has two hard disks. One is a 500 GB NTFS empty drive and the other is a 160 GB ext4 drive. My plan is to make the 500 GB as the file sharing disk.

When I share a folder like ~/Documents using Nautilus context menu on machine #2, I can access the files easily on both #1 and #3, but when I try to share some folder on 500 GB disk, I get an error on machine #1 that says

Failed to mount windows share

I do not mind formatting the drive to ext4 if needed, but I am sure that something simple is wrong.


I took @Marty's comment as a hint and used ntfs-config to configure automount of that partition. It is working now. Thanks

  • How are you mounting the 500GB drive? In other words, are you mounting it in /etc/fstab, or relying on automatic mounting in /media? – Marty Fried Jun 14 '12 at 4:50
  • The ubuntu machine is always on. I just mount it using Nautilus. Click on the side pane. – Ranjith Ramachandra Jun 14 '12 at 4:57
  • 2
    Hey. I just took your comment as a hint and used ntfs-config to configure automount of that partition. It is working now. Thanks. – Ranjith Ramachandra Jun 14 '12 at 5:19
  • 1
    Glad I was able to help you help yourself - that's the best way, IMO. :) – Marty Fried Jun 14 '12 at 15:48
  • @shortfellow please add this an answer and mark it as the accepted answer if it solves your problem. Thanks! – lazyPower Jan 20 '14 at 19:32
up vote 3 down vote accepted

I ended up using ntfs-config. The automount feature on it solved my problem.

What you want to do is add a "force user" line to that share definition so that the remote user appears to be you

  comment =   
  path = /media/some-name  
  read only = No  
  force user = your-user-name  
  guest ok = yes 

Try this.

I tried to set "name resolve order = bcast host" and even scratching my head trying to find solutions from the net.

My problem was simply this:

I have samba running on my Ubuntu server, and my laptop which also runs Ubuntu was unable to browse the shared folders. I had the folder permissions set to 700 which allows only user to be able to have read write and executable permissions.

But the problem only my Ubuntu was unable to browse those folders. My windows, Ipad and android able to browse and execute files.

After adding "force user = myusername", everything works like a charm.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.