0

I still need further help for installing the NVIDIA driver properly for my geforce gt 730 gpu on my Ubuntu 20.04 machine, since all methods I tried have failed, I had no luck. It continues to give me this error even reverting to the ga kernel as @DanielT said:enter image description here

5
  • Welcome to Askubuntu! If you simply need to install the proprietary drivers, have you tried sudo ubuntu-drivers autoinstall? Also, we would need to know the methods you've already tried and a description of why they failed to know what the problem is and how to determine a solution. Thanks.
    – mchid
    Mar 3 at 23:21
  • @mchid The previous question is askubuntu.com/q/1506293/1004020 , but the question has gone outside my knowledge area
    – Daniel T
    Mar 3 at 23:23
  • Related to that '-' error might be askubuntu.com/q/969352/1004020 . Please edit and copy-and-paste the output of ls /boot ; cat /var/lib/dkms/nvidia-340/340.108/build/make.log
    – Daniel T
    Mar 4 at 3:49
  • 1
    Maybe my question How can the NVidia driver 390 be used with kernel 6.2 (23.04) is of some (dissatisfying) interest to you. I tried to use GT520 cards, but the last supported NVidia driver is the same. Which driver you can use depends on the kernel version.
    – zx485
    Mar 4 at 4:12
  • The screenshot does not show the GA kernel being used. Mar 4 at 12:14

3 Answers 3

3

With the combination of Nvidia drivers and kernels available from the Ubuntu 22.04 repos, I do not think you can do it.

I have a GT 730 as well and I have not been able to get it to run the Nvidia driver other than 340 on any Ubuntu newer than 20.04 with the GA kernel (currently 5.4.0-172-generic)

If I go HWE in 20.04, I can not get it to work, nor can I get it to work in 22.04.

+------------------------------------------------------+                       
| NVIDIA-SMI 340.108    Driver Version: 340.108        |                       
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GT 730      Off  | 0000:01:00.0     N/A |                  N/A |
| 33%   27C   P12    N/A /  N/A |     43MiB /  2039MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
--------------- 
OS: Ubuntu 20.04.6 LTS x86_64 
Host: M11AD 
Kernel: 5.4.0-172-generic 
Uptime: 6 mins 
Packages: 2067 (dpkg) 
Shell: bash 5.0.17 
Terminal: /dev/pts/0 
CPU: Intel Pentium G3220 (2) @ 3.000GHz 
GPU: NVIDIA GeForce GT 730 
Memory: 246MiB / 7885MiB 

This is what flashed on the screen before login when I tried the 470 driver.

enter image description here

Research by @mchid unearthed that the particular version of the card I have, namely PCI Device ID 0x0f02, is known not to work with the 470 driver; other versions may.

I would love to be proven wrong.

1
3

Your installation error is because you did not remove the HWE kernel. nvidia-340 will not work with 5.15.0-67-generic. It will only work with 5.4.0-172-generic, as I tested in a 20.04 Docker container. You need to have exactly one kernel installed, and no other kernels for the nvidia-340 driver to work. One line of dpkg: error: version '-' has bad syntax: revision number is empty appears for each kernel version you have, and you have 3, which is 2 more than desired.

Furthermore 5.15.0-67-generic does not even exist in the repositories right now. The closest is 5.15.0-97-generic. Perhaps you forgot to run apt update for a long time, disabled automatic package list fetching, or installed a custom kernel. Anyway, since usual HWE removal steps didn't work for you, let's try something more forceful:

sudo -i

apt update
apt purge nvidia-340
dpkg --configure -a
apt upgrade
apt dist-upgrade

# If the next step fails, don't reboot until you do `apt install linux-generic`
dpkg --get-selections | cut -f1 | grep '^linux-[^:]*[[:digit:]]' | xargs apt purge
apt install linux-headers-5.4.0-172 linux-headers-5.4.0-172-generic linux-image-5.4.0-172-generic linux-modules-5.4.0-172-generic linux-modules-extra-5.4.0-172-generic

apt install nvidia-340
9
  • how can i delete the former two kernels i have?
    – Davi SN
    Mar 4 at 4:38
  • @DaviSN The dpkg --g[...] purge step will delete all the kernels. Then the next step will install the exact version you need
    – Daniel T
    Mar 4 at 4:43
  • I found that network does not work with 5.4.0-172-generic, so how can I fix this?
    – Davi SN
    Mar 4 at 4:44
  • @DaviSN Idk about your network. You can't have any other kernels installed if you want your Nvidia driver working. And for your network problem, you can ask another question after you get your Nvidia working
    – Daniel T
    Mar 4 at 4:45
  • in order for me to install the nvidia driver on the kernel I said above, I will need to fix this problem since network works on 5.15.0-67-generic. Can you help me?
    – Davi SN
    Mar 4 at 4:52
2

Edit: if the following command returns a result for your GPU or VGA device, then this answer doesn't apply to you (use driver 390 instead of 470).

hwinfo --gfxcard | grep -i 0f02

According to the Nvidia website, the GeForce GT 730 should be using driver 470 (this does not apply to the GeForce GT 730 with PCI ID 0f02)

First, make sure your system is fully up to date or you will encounter issues:

sudo add-apt-repository restricted
sudo apt update
sudo apt dist-upgrade

Then reboot.

After a reboot, proceed with the installation:

sudo apt install --install-recommends nvidia-driver-470

When it's done, you will need to reboot to apply the changes.

8
  • 1
    I just tried it, and it didn't work. A black screen came up before the login with the text "The Nvidia GeForce GT 730 GPU in this system is supported through the 390 legacy driver...The 470 driver will ignore this GPU" and it came up using nouveau. So it's pretty clear that driver doesn't support the GT 730 - it told me so! The source of your information appears to be incorrect. Mar 4 at 2:15
  • 1
    I added a screenshot of the message to my answer. Mar 4 at 2:55
  • 1
    @OrganicMarble Okay yeah, it shows there is one GT 730 that's only supported by the 390 driver that has PCI ID = 0F02
    – mchid
    Mar 4 at 3:14
  • 1
    Wow, I lucked out when I bought that card for $20 off ebay for testing!! Or not. Mar 4 at 3:29
  • 1
    I had to look before bedtime - sure enough, it's "PCI Device ID 0x0f02" lol! So have an upvote. Mar 4 at 4:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .