0

After upgrading his computer to Ubuntu 12.04, my Granddad's reports in all of his LibreOffice databases no longer work, even though the underlying queries still work. Sorry for so little diagnostic information; I don't know much about Base, so I don't even know where to begin debugging this problem.

  • @ObsessiveFOSS Thank you, I understand that (look at my network profile and you will see that I have fairly high rep on some sites). The reason why I hadn't gotten around to accepting some of the answers is that on some of my questions, my own answer was the one that ended up fixing the problem. – Kazark Jun 13 '12 at 23:06
  • You can accept it and looking on Meta Ask Ubuntu, it is the accepted norm to accept self-answers. – hexafraction Jun 13 '12 at 23:07
  • @ObsessiveFOSS Yes sir, I understand. I'm just saying that I hadn't got around to doing it because you can't accept your own answers at first, and then I hadn't remembered (I don't check this site as regularly as some of the others). – Kazark Jun 13 '12 at 23:09
  • Ok, sorry for misunderstanding. – hexafraction Jun 13 '12 at 23:09
1

I had almost the same problem - libreoffice reports didn't work at all.

Entering the following in a terminal solved my problem:

sudo apt-get install libreoffice-report-builder
1

I had a similar problem recently. Following the steps in the third post here resolved it for me:

http://en.libreofficeforum.org/node/2589


EDIT: Resource appears to have disappeared. Here was the original text:

Possible solution to opening legacy database reports in LO v3.5 After much trial-and-error sleuthing, I may have hit upon a solution to this apparent problem (reported here by me several weeks ago). It involves adding a 'missing' hidden form control (see steps below). I'll be interested to know if this actually helps anyone with problems running legacy database reports under LO.

  1. Open your legacy report for EDITING in the usual way (right-click and choose 'Edit').

  2. Now open the FORM NAVIGATOR (button).

  3. Under the 'Report source' item you should see these controls - CommandType, QueryName, Command, GroupFieldNames, FieldNames, RecordFieldNames. If there is NOT an item named 'Sorting', you must add it. I found it 'missing' in my legacy reports (created in OO), and when I added it, the reports run properly! (Perhaps this 'Sorting' hidden control has been added at some stage of LO development?)

  4. To add the 'Sorting' item, just do these steps:

    • Right-Click on the enclosing item 'ReportSource'
    • Under the NEW item pop-up menu select 'HiddenControl', and a new control will be created in the end of the list of existing controls (probably under the item 'RecordFieldNames').
    • Now, change the name of this new control to 'Sorting'.
    • To do this, right-click on the new item, and choose PROPERTIES from the pop-up menu.
    • In the resulting window/pane, change the (Hidden Control) name to 'Sorting' (type exactly - no quotes, and with a capital 'S') and close the window.
    • You should now see an item called 'Sorting' at the end of your list of hidden control for your report source item.
    • Close the Form Navigator window and SAVE the report.
  5. Your legacy report should now run/open as it used to under OpenOffice.

  • I tried what I could from there and it didn't seem to fix it, even though some of the things he said (missing "Sort" field etc) were true. – Kazark Jun 13 '12 at 23:45
  • Sorry I can't be of more help. That worked for me. – Alex L Jun 14 '12 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.