3

My PC configuration includes a 4th generation Intel Core i3 processor, Intel(R) HD Graphics 4400, 8GB of RAM, and a 128 GB SSD. My monitor is a 19 inch Gigasonic, connected by HDMI. When I used Windows, my display resolution was 1366x768.

Windows

However, when I switched to Ubuntu, my display resolution became 1024x768. I tried to set a custom resolution, but I failed.

Ubuntu

How can I solve this problem? Can I use a 1366x768 resolution with Ubuntu, or should I switch back to Windows?

3
  • Hi - Can you please edit your question to add: What Ubuntu version have you installed? What type of monitor are you using, and connected via what mechanism (HDMI, DVI, USB, etc.)? Commented Feb 26 at 4:45
  • That 76Hz looks suspicious. Have you tried askubuntu.com/q/1504000/1004020 ?
    – Daniel T
    Commented Feb 26 at 4:45
  • You can try changing your cable connector. Sometimes, a defective connector is the reason why your monitor is stuck in a low resolution. If that doesn't work, you can use a spare monitor, if you have one, to see if you can set a custom resolution there. If that works, can you try using the old monitor again to see if the custom resolution will retain.
    – Gabriel
    Commented Feb 26 at 5:11

1 Answer 1

2

It sounds like you're having a bit of a pickle with your display resolution on Ubuntu. Don't fret, mate! You should be able to tweak those settings and get things sorted out without having to hop back to Windows.

First off, have you tried checking if Ubuntu recognizes your monitor correctly? Sometimes, the system might not detect it properly, which could mess with your resolution settings.

Next, let's see if we can manually set that 1366768 resolution. Open up your Terminal and type in xrandr to see the available resolutions. If 1366768 isn't listed, we might need to add it manually.

To do that, you'll need to create a new mode with cvt. It goes a little something like this:

cvt 1366 768 60

This command generates a Modeline for a 1366*768 resolution at 60Hz. Once you have that, copy the output starting from "Modeline" (excluding the word "Modeline") up to the end.

Then, use xrandr to add this new mode:

xrandr --newmode <paste the modeline here>

After that, you need to add this new mode to your display:

xrandr --addmode <your display name> 1366x768_60.00

Finally, you can set your display to use this new resolution:

xrandr --output <your display name> --mode 1366x768_60.00

Replace <your display name> with the actual name of your display, which you can find using xrandr.

Give that a whirl and see if it sticks! If it doesn't work right away, you might need to do a bit of tinkering or dig deeper into your graphics drivers. But with a little perseverance, you should be able to get that sweet 1366*768 resolution up and running on Ubuntu. No need to wave goodbye to Windows just yet!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .