0

Keys “g”, “h”, “‘“, “7” on numpad (also Home) and Escape do not work properly on Ubuntu 22.04 and did not work on Linux Mint, which was the previous operating system on my laptop (Lenovo IdeaPad S340-15API 81NC009KRK). The most interesting is that it happens with all of them at once. I mean, if at least of one them is ok, then every other key can also type well. If they do not type, pressing them for a while or simply hitting them multiple times can temporarily fix that, but it is very inconvenient to write code like that.

I can exclude any hardware issue, since, first of all, each key types well in BIOS. Second of all, I have already been to a local computer repairing service several times, and they told me that the keyboard’s physical state is ok.

I am looking forward to literally any solution, as I am not afraid of a data loss on the computer, because all the data has already been backed up.

upd: neither evtest nor xev display anything after pressing those keys when they do not work. If they do, the output for both (respectively) is as follows:

gEvent: time 1708281834.079588, type 4 (EV_MSC), code 4 (MSC_SCAN), value 22
Event: time 1708281834.079588, type 1 (EV_KEY), code 34 (KEY_G), value 0
Event: time 1708281834.079588, -------------- SYN_REPORT ------------
KeyRelease event, serial 43, synthetic NO, window 0xa00001,
    root 0x3c6, subw 0x0, time 618602, (133,184), root:(134,248),
    state 0x0, keycode 42 (keysym 0x67, g), same_screen YES,
    XLookupString gives 1 bytes: (67) "g"
    XFilterEvent returns: False

upd2: I tried those keys on Windows 10 booted from USB, and they typed well in CMD. I have also never missed an opportunity to test them in BIOS, and they have always worked fine. Both of these things say that it is not a hardware problem.

12
  • Please edit with what evtest outputs the moment after you press those keys. If it doesn't output anything, then you might have pressed enabled some kind of function key or gamer mode on the keyboard. If it detects the keypresses but xev does not, you might need to find and enable the correct keyboard layout
    – Daniel T
    Feb 18 at 18:25
  • 1
    If "neither [...] when they do not work" then it's unlikely a Ubuntu problem. The mostly likely solution is to hold the function key on your keyboard, and look for a blue lock or a gaming mode icon on another key
    – Daniel T
    Feb 18 at 19:27
  • @DanielT, could you please provide a bit more details on what exactly should I do? What is 'a blue lock' and where I can see 'a gaming mode icon on another key'? Feb 19 at 2:26
  • @WinEunuuchs2Unix, I tried deleting the whole config folder and rebooting the laptop, but, unfortunately, it did not help Feb 19 at 2:30

1 Answer 1

0

Solved by switching to Windows. Maybe I will install Ubuntu as dual boot

Not the answer you're looking for? Browse other questions tagged .