1

It all started with Visual Studio Code installed via snap. There was an update, but the button was grayed out. From the terminal I tried to remove VSCode but I got the following error message:

sudo snap remove code
error: snap "code" has "auto-refresh" change in progress

From now on, I tried everything I found on similar questions including:

  • rebooting
  • removing snap cache
  • removing snap user data (in home)
  • removing snap entirely from Ubuntu (it failed)
  • reinstalling snap trying to install sudo snap refresh --beta core22 (failed as well)

The current situation is:

/var/lib/snapd$ sudo snap list
Name                                  Version                     Rev    Tracking         Publisher      Notes
bare                                  1.0                         5      latest/stable    canonical\u2713     base
chromium                              121.0.6167.160              2749   latest/stable    canonical\u2713     -
code                                  05047486                    150    latest/stable    vscode\u2713        disabled,classic
core                                  16-2.61.1                   16574  latest/stable    canonical\u2713     core
core18                                20231027                    2812   latest/stable    canonical\u2713     base
core20                                20240111                    2182   latest/stable    canonical\u2713     base
core22                                20240206                    1194   latest/beta      canonical\u2713     base,disabled
cups                                  2.4.7-3                     1024   latest/stable    openprinting\u2713  -
firefox                               122.0.1-1                   3779   latest/stable    mozilla\u2713       -
firmware-updater                      0+git.e8771be               109    latest/stable/\u2026  canonical\u2713     -
gnome-3-28-1804                       3.28.0-19-g98f9e67.98f9e67  198    latest/stable    canonical\u2713     -
gnome-42-2204                         0+git.ff35a85               141    latest/stable/\u2026  canonical\u2713     -
gtk-common-themes                     0.1-81-g442e511             1535   latest/stable/\u2026  canonical\u2713     -
hexpad                                1.7                         9      latest/stable    caozhen        -
kde-frameworks-5-99-qt-5-15-7-core20  5.99.0                      7      latest/stable    kde\u2713           -
openscad                              2021.01                     339    latest/stable    torsten-paul   -
snapd                                 2.61.1                      20671  latest/stable    canonical\u2713     snapd
snapd-desktop-integration             0.9                         83     latest/stable/\u2026  canonical\u2713     -
vlc                                   3.0.19                      3721   latest/stable    videolan\u2713      -

Now I am reinstalling to get rid of this message and restore snap.

My questions are:
Why there isn't a clear recovery path from a damaged snap status?
Should I stay away from snap in my new installation?

[Edit]

After removing completely snap and the snap-store I reinstalled as for https://snapcraft.io/install/snap-store/ubuntu#install and then run: sudo snap refresh snap-store --channel=latest/stable/ubuntu-23.10

This operation disabled the snap-store and now it's 6 days that nothing can be done.

raf@vmhw:~$ sudo snap changes
[sudo] password for raf: 
ID   Status  Spawn                     Ready  Summary
5    Abort   6 days ago, at 14:16 CET  -      Refresh "snap-store" snap from "latest/stable/ubuntu-23.10" channel
  
raf@vmhw:~$ sudo snap remove snap-store
error: snap "snap-store" has "refresh-snap" change in progress
6
  • Unfortunately sudo snap abort did not abort the operation. I waited a long time but it didn´t work.
    – raf
    Commented Feb 16 at 16:49
  • Does this answer your question? Snap not allowing me to remove or refresh anything Commented Feb 17 at 11:35
  • @guiverc sorry, you're right. It's 23.10
    – raf
    Commented Feb 17 at 15:29
  • @ArturMeinild I read that article but it didn't work. sudo abort was suggested in other threads as well, but it never ended and I had to stop it after half a day. I am trying to understand how to completely refresh snap (removing everything and re-adding snapd) but there is not a documented path for 23.10. I manually removed everything and re-added as for the documentation, but I ended up in being an old snap version. After that I run snap refresh snap-store --channel=latest/stable/ubuntu-23.10 and now it's 15 hours running and apparently hung.
    – raf
    Commented Feb 17 at 15:35
  • 1
    @guivercThe initial message was there for two days. It was clearly stuck. If two days is an expected duration, the message should provide at least a progress on the expected duration.
    – raf
    Commented Feb 18 at 9:27

1 Answer 1

0

The radical steps I did last week to recover snap were:

  • reboot
  • totally removing snap
  • reinstalling snap (I only found the official guide for Ubuntu 22)
  • reboot
  • upgraded the snap channel using snap refresh snap-store --channel=latest/stable/ubuntu-23.10
  • reboot

Last week they did not work. Last friday I repeted these and they worked. After waiting a few days I can tell it worked.

The only difference are that Ubuntu shipped in the meantime a lot of updates, including snap-related updates. These apparently fixed the snap issues.

I hope this can help someone else and thanks to the people trying to help me. From what I could see, snap is still quite rough and still needs some robustness. Today I installed a new VM and I could only update snap from the command line after logging out. This is not a great UX.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .