I'm using Ubuntu 11.10, and when running in GNOME Classic I no longer see an icon for the nm-applet in the top panel. However the applet is running:

jsteele@jsteele-00:~$ ps aux | grep nm-applet
jsteele   2767  0.0  0.2 454584 16576 ?        Sl   08:57   0:01 nm-applet
jsteele   3304  0.0  0.0   9260   900 pts/0    S+   09:32   0:00 grep --color=auto nm-applet

I noticed that I can actually click on the far right "pixel" of the panel and I get the nm-applet menu (so it is present and functional, just not visible). Ideally I would like an icon to be visible.

In Unity the nm-applet icon is present and operates as I would expect - is this a compatibility issue between Unity and GNOME Classic?

(Possibly similar to this question, but doesn't indicate that the applet is still operational and sufficiently different for me to raise this separate question; equally there isn't an answer that resolves the issue for me: Network Manager icon doesn't appear in top panel)

  • please add a link to a screenshot showing your issue. Are you using the standard gnome-applets or the 'indicator-applet-complete' as per my answer here: askubuntu.com/questions/69377/… – fossfreedom Jun 15 '12 at 11:42
  • What is your installed gtk+2.0 version? – jasmines Jun 15 '12 at 12:18
  • I believe this demonstrates the "invisible nm-applet" problem you're experiencing:

    right-click invisible nm-applet

  • Running nm-applet from the terminal gave me this debug information, which leads me to believe that the behavior you see is a side effect of this known bug regarding visibility of the nm-applet indicator in non-Unity environments. The bug has been fixed in Precise, but NOT for Oneiric 11.10.

Solution: Do what Precise 12.04 does: use Gnome's indicator-applet-complete!

  • Gnome Classic in 12.04 doesn't have this problem, because it uses a different indicator package that "wraps" nm-applet's functionality (making the bug--fixed or not--irrelevant)

  • As fossfreedom noted in the comments to your question, the indicator-applet-complete package is also available for 11.10 in a PPA. Installing it is your best alternative.

  • To do so, open the terminal and:

    sudo apt-add-repository ppa:jconti/gnome3 -y
    sudo apt-get update
    sudo apt-get install indicator-applet-complete
  • To activate it, let's first remove the existing indicators. Press Win+Alt and carefully right click on the little vertical bar as shown below, and click remove from panel:

    enter image description here

  • You'll get an error, just click on Reload -- it won't reappear. Do the same to remove the user indicator from the panel too.

  • Now Alt+ right-click on the empty panel, and click on Add to Panel, which will show you this:

    enter image description here

  • Scroll down, select Indicator Applet Complete and click on add, to get the Unity-style indicator bar, including network, sound and user....and that's it!

    enter image description here

| improve this answer | |
  • 1
    Amazing detailed answer - solved the issue while being a pleasure to read :) – CodeButcher Jun 20 '12 at 16:00
  • thank . you . so . much :) this was driving me bonkers! Note, this worked for me on Ubuntu 14.04. The indicators seemed to disappear after a routine system update. However, in my case, I did not need to sudo apt-add-repository ppa:jconti/gnome3 -y. The steps of removing items from the panel, and then doing "add to panel" worked for me. I also did sudo apt-get purge indicator-applet-complete and sudo apt-get installed indicator-applet-complete but I'm not sure if that was necessary. – Michael Bylstra Feb 21 '16 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.