I have ppa:cr3/ppa in my sources list. It upgrades my checkbox, checkbox-gtk, and checkbox-qt packages to version 0.14~ppa6.12.04. And now I have problems with updating my system, and sometimes critical system errors.

I tried to use ppa-purge to downgrade them - it didn't work. I tried to delete them from synaptic - it wants to delete ubuntu-desktop with them.

When I try to update system I'm getting an error:

E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I solve this problem?

  • 1
    Deleting ubuntu-desktop shouldn't be a problem. We can reinstall them later on.. It's a meta package at best. – jokerdino Jun 13 '12 at 7:47
  • 3
    I recommend adding the output of ppa-purge to your question. (You can run it again to get the error output, if you no longer have it up.) – Eliah Kagan Jun 13 '12 at 7:51
  • I can't do it... to much of characters.... – Simplehuman Jun 15 '12 at 10:00

You should be able to force version for those packages, setting them to use the official repository one doing a click on each of them in synaptic, then package menu -> force version...

Once you set them back, feel free to remove third party repos and upgrade safely.

|improve this answer|||||
  • Thank you for your answer. For checkbox-gtk and checkbox-qt it works. But checkbox is remaining 0.14~ppa6 :( I am getting the same error message. – Simplehuman Jun 15 '12 at 9:50
  • checkbox version in official 12.04 repos is 0.13.7. Try forcing it manually with sudo apt-get install checkbox=0.13.7 – jasmines Jun 15 '12 at 9:58
  • I have purged all of them with ubuntu-desktop package ... And just install them again . Everything is working, thank you. – Simplehuman Jun 15 '12 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.