I am using ubuntu 12.04 with Nvidia Geforce 6150SR graphic card.In 12.04 Ubuntu does not recognize a screen resolution 1440x900 for my monitor "Flatron L177WSB".I tried this method,but not working.It fails from 5th step. Terminal shows

Failed to get size of gamma for output default

I am using AMD athlon 64x2,1GB memory.


I had the same problem as you, normaly this is caused by a problem with X.org reading the EDID file from your monitor with the resolutions...

The solution is to edit the /etc/X11/xorg.conf file like this :

If you don't have this file then you have to create it from scratch, just let the Nvidia software do it for you using this command on the terminal :

sudo nvidia-xconfig

If you already have an xorg.conf file, then you'll just have to edit (or create one if he doesn't exist), as root, like this:

gksu gedit /etc/X11/xorg.conf

And copy this lines on the "Section Device":

    Option         "UseEDID" "true"
    Option         "IgnoreEDIDChecksum" "CRT,DFP,TV" 

If you are using and HDMI cable (for example), and the image is not scaled then add this line just after the other ones:

    Option         "FlatPanelProperties" "Scaling = Native"  

Now just logout and login again, Open the "Nvidia X Server Settings" and see if all the resolutions available by your display are available.

I hope this helps.

  • The result is terrible.Now the only available resolution is 640x480.
    – Kiranraj
    Jun 13 '12 at 1:11
  • Here is my xorg.conf as such..
    – Kiranraj
    Jun 13 '12 at 1:15
  • Could you please remove the xorg file, logout and login, and then install read-edid like this "sudo apt-get install read-edid" and then write this on the terminal "sudo get-edid | sudo parse-edid", post it on "pastebin.com" (for example) and then send me the link so I can see the problem ?
    – aliasbody
    Jun 13 '12 at 1:19
  • how can i remove xorg file?
    – Kiranraj
    Jun 13 '12 at 1:21
  • 1
    I've found the information here (ubuntuforums.org/archive/index.php/t-1250971.html) someone with a similar problem, but using the same screen as you.
    – aliasbody
    Jun 13 '12 at 2:28

I am assuming you install the Proprietary drivers or even have the Nvidia PPA (x-swat). So with that in mind I can offer the following help:

What I would suggest is to first delete the monitors.xml file that should solve some resolution problems. The file can be found in ~/.config. Or go to a terminal and type sudo rm -fr ~/.config/monitors.xml

Now restart to see if it shows the resolution you want.

If the problem persists open the nvidia-settings GUI program. Go to dash an type nvidia, you should see the nvidia settings program. Open it and look for the resolution option in there. Test it out.

UPDATE: If you want monitors.xml back, here is mine, you can change the lines to fit your resolution:

<monitors version="1">
      <output name="default">
  • not working and res gone to 640x480.Again terrible
    – Kiranraj
    Jun 13 '12 at 2:21
  • how can i replace that file?
    – Kiranraj
    Jun 13 '12 at 2:22
  • Updated to include the monitors.xml content. Jun 13 '12 at 2:56
  1. open the NVIDIA X Server Settings and select the "X Server Display Configuration".

  2. Click "Save toX Configuration File" and Check the path is "/etc/X11/xorg.conf"

  3. Modify here as you need.

    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "CRT: nvidia-auto-select +1920+180, DFP: nvidia-auto-select +0+0"
        SubSection     "Display"
        Depth           24




  4. logout & login


Have you tried obtaining your drivers from the nvidia site? Nvidia

  • I have 295.53 thelatest one...
    – Kiranraj
    Jun 13 '12 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.