I am having issues with my audio on Ubuntu 12.04, I will try and give as much detail as possible so sorry if there's too much detail.

The Problem

  • Audio plays from both speakers and headphone regardless of what connector I choose and regardless of the profile I use.
  • The microphone is constantly being played through headphones & speakers.
  • The headphone audio is extremely quiet but plays from both ears when I select "Headphones" for the connector in Sound Settings.
  • The headphone audio only plays from one ear and is quiet (but not as quiet as above) when I select "Analogue Output" for the connector in Sound Settings.

I can only select "Headphones" as the connector in Sound Settings if I set the profile to either "Analogue Stereo Output/Duplex", all others only allow me to choose "Analogue Output" for the connector.

Despite the headphone sound issues, the speaker sound is fine apart from the fact that I am not able to select which output is used, they just both play.

My headphone and microphone are plugged into the front and my speakers are plugged into the back.

What I have tried

I have put everything in alsamixer to 100 apart from "Front Mic Boost" which I have set to 0.

Command Output

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: AD198x Headphone [AD198x Headphone]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 2/3
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2

cat /proc/asound/cards

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf7ff8000 irq 70

cat /proc/asound/modules

0 snd_hda_intel

cat /proc/asound/card*/codec* | grep "Codec"

Codec: Analog Devices AD1989B

cat /etc/modprobe.d/alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Hopefully I have provided enough information, I will happily provide anymore information needed. Thank you.


Reinstalling alsa-base and pulseaudio fixed the headphone issues I was having.

  • You may want to separate each problem into its own question. – nanofarad Jun 12 '12 at 17:52

Is your sound card a 5.1 surround sound card ? If so I have a solution that worked for me and it solved my Microphone issues as well.

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo apt-get install gnome-alsamixer
sudo apt-get install indicator-sound
sudo alsa force-reload

Reboot computer after this point.. you will get 5.1 surround sound. To test it type

sudo speaker-test -c6

Oh and after you reboot if you don't hear surround sound you might need to type in your terminal alsamixer and change the setting there from 2 channel ( ch2 ) to 6 channel ( ch6 ). You will even need to edit that one config file to set it there too.

gksu gedit /etc/pulse/daemon.conf

Change the setting of default-sample-channels = 2

to : default-sample-channels = 6 ( This might be commented out with ; or #, uncomment it )

You might need to reboot a second time after you edit that file and setup the alsamixer to 6 channels.

EDIT UPDATE : Even if you do not have surround sound, you can still remove and install using the commands above. They will allow you the alsamixer in a much more cleaner install. Then open alsamixer and try the Microphone again after a reboot.

  • Reinstalling alsa and pulseaudio seems to have fixed the headphone being quiet or playing from one ear. – Lerp Jun 12 '12 at 18:12
  • Hope I was helpful in some way. Glad you got it somewhat fixed. I am still not sure what other help you need though. – TorakTu Jun 12 '12 at 18:18
  • Just a small note for any future readers I had to reinstall the sound indicator after reinstalling pulseaudio with: sudo apt-get install indicator-sound – Lerp Jun 12 '12 at 18:47
  • Added that to my ANSWER above. Thanks for the tip. I had installed that before but forgotten about it. Thanks again. – TorakTu Jun 12 '12 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.