0

Yesterday everything was fine, then when I rebooted my computer I got this:

enter image description here

I'm not a Ubuntu guru so I don't know what to do here. I tried reinstalling my nvidia drivers, but no luck. Did anyone encounter something like this before?

I tried to update / upgrade my distribution also, but that did not work either. Any help would be appreciated!

2
  • Are you sure it is not a hardware error? What is displayed wuting boot? Do you have the whole picture during boot and login?
    – nobody
    Commented Jan 12 at 13:42
  • yes i do during both, also i have dual boot with windows and windows works fine! i also tried logging in and out, but no difference Commented Jan 12 at 13:50

2 Answers 2

1

I'm having the same issue, it seems to be some recent resolution change that's causing it. The screen gets cut in half after login and blinks. If i connect it to an external screen using HDMI. The resolution resizes and the screen is proper on both my laptop as well as on the external screen. My dual boot Windows works perfectly. Ubuntu works perfectly up to the login screen. This isn't a hardware issue.

As mentioned in the other answer, ill simply elaborate the steps -

  1. On start when you enter the grub screen where you choose between Ubuntu and windows, below Ubuntu you will see the option for advanced options.

  2. Press enter and now you will see different Linux Kernel versions. My default was 6.5.0-14-generic which got the half screen bug. I selected the lower one - 6.2.0-39. After login, my desktop opened with the problematic resolution.

  3. Once you enter Ubuntu with 6.2 kernel, check your resolution in your settings. I faced this issue with kernel 6.5 in 1920x1080. I changed the default resolution to higher resolution - 25600x1440 and then restarted from the old (6.5) kernel and it worked fine.

In my case I had connected laptop to a screen with very low resolution and that seems to have messed up the default resolution.

1
  • It is super weird but indeed, setting to 2560x1440 fixes the issue, afterwards if I go back to 1920x1080 I get the same issue. However, if we enable "fractional scaling" then we can set the scale to 125% or 150% and get the same effect as with 1920x1080. Commented Jan 24 at 8:20
0

I've got the same problem with integrated graphics. And I have dual boot with Windows too and Windows works fine. In my case, I've downgraded Linux to 6.2.0 as it was 6.5.0. Now everything works fine. I've written a letter to AMD support team to find the solution. Hope my case is useful.

2
  • how do downgrade? did it also happen out of the blue for you? Commented Jan 12 at 15:36
  • at the boot screen, if i go to advanced options, and select the previous linux distro, indeed 6.20 and not 6.5.0 it works again. i guess for now i will be doing this. Commented Jan 16 at 12:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .