I purchased world of goo from the Ubuntu Software Center about a month back and it works fine. Recently though when I perform a sudo apt-get update I get the following output.

W: Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/world-of-goo/ubuntu/dists/precise/main/binary-amd64/Packages  The requested URL returned error: 401
W: Failed to fetch https://private-ppa.launchpad.net/commercial-ppa-uploaders/world-of-goo/ubuntu/dists/precise/main/binary-i386/Packages  The requested URL returned error: 401
E: Some index files failed to download. They have been ignored, or old ones used instead.

Can someone explain what all this means and what I can do to have it properly updated?

Edit: I ran the following at the bash command line

/etc/apt/sources.list.d/*.list | grep ppa

Which yielded the following output relevant to world of goo:

deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/world-of-goo/ubuntu precise main #Added by software-center; credentials stored in /etc/apt/auth.conf

Edit 2: I have submitted a bug report to software-center on launchpad and written to the publisher.


  • 2
    401 is unauthorized – Dr_Bunsen Jun 12 '12 at 12:05
  • @Dr_Bunsen so what does that mean? Are updates not included as part of the purchase of World of Goo? – mcheema Jun 12 '12 at 12:39
  • 1
    I dont know, only thing I know you arent able to reach it – Dr_Bunsen Jun 12 '12 at 12:41
  • @Dr_bunsen: Ok that does help as it narrows down what is wrong. Is it proper etiquette to rephrase the question or should I wait for some more responses and then depending on that ask a new question about authorization for updates? – mcheema Jun 12 '12 at 12:48
  • 1
    It really doesnt matter that much, it's the internet, so do what you think is best. As long as you are not spamming, it's fine(maybe some people will agree with that, but whatever). If I were you, I would edit this question. And you should try to contact those world of goo people, I mean, it's their game, and it costs just a little too much for not getting it. – Dr_Bunsen Jun 12 '12 at 14:54

I have received a notification from the developers of software-center-core on launchpad that this is a known bug and that they are in the process of resolving it. The bug manifests itself In many different ways on the server side of Ubuntu software center and the primary thread discussing it can be found at:


Update: As of 22nd June there is still no resolution to this problem.

Update: As of 29th June it appears that there is no solution from Ubuntu Software Center. It seems that there are just too many issues so I am now just going to ask for a refund and look back in a year or two when the store software is more mature.


Found this:

solution has been the following:

Log into Launchpad www.launchpad.net

Go To your account by clicking on your name in the upper right of your browser.

Click on "View your private PPA subscriptions" - located at bottom of screen

Choose View on the previously purchase software listing on this page. - 'VIEW'

Under "Custom sources.list entries" there are 2 lines that show your private ppa information. Copy the first line. (deb https://username:password@private-ppa.launchpad.net/commercial-ppa-uploaders/SOFTWARE/ubuntu YOUR_UBUNTU_VERSION_HERE main #yada yada yada)

Open Update Manager and click Settings.

When the Software Sources window comes up go to 'Other Software'

Remove the Entry that failed

Enter your Admin password when prompted.

Paste the line you copied from Launchpad and edit YOUR_UBUNTU_VERSION_HERE (I'm under 12.04 so I put precise there).

Click Add Source then Add the next line (deb-src line) and edit the YOUR_UBUNTU_VERSION_HERE to your version and hit Add Source.

Click Close on the Software Sources and Refresh.

Open Terminal (CTRL+T) and type

sudo apt-get update

sudo apt-get install 'PACKAGE NAME'

Hope this helps.. Worked for me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.