0

My current GNOME desktop looks like this:

enter image description here

where the dock is below the desktop, and it is visible only after I click Activities.

But I saw other people's GNOME desktop looks like this:

enter image description here

where the dock always shows up to the left.

Do you know how to change the looking of my desktop to the second one? Thanks.

========== Edit ===========

I have tried hard, but the desktop is always dock-style. Below is a screenshot where I specified the desktop to be ubuntu:GNOME at login, but it's still dock. I'm starting to suspect that Canonical forces Ubuntu 22.04 users to use dock desktop no matter what. If you are an employee of Canonical or an insider who can confirm my suspicion, I'll appreciate it because I don't have to waste time trying to change the desktop back to dash any more.

enter image description here enter image description here

2 Answers 2

1

Go to Settings > Appearance and navigate down to Dock > Position on screen`` after which select the down arrow and select Left`.

You can also select right if that would be your preference.

enter image description here

6
  • My settings doesn't have Appearance option.
    – zzzhhh
    Dec 26, 2023 at 12:12
  • @zzzhhh that is quite odd. My instance (from where the image was produced) is GNOME version 42.l9 using X11 as the windowing system on Ubuntu 22.04. Are you sure you are using GNOME as your desktop environment. You can check which one by typing echo $XDG_CURRENT_DESKTOP in the terminal. You should get Ubuntu:GNOME
    – graham
    Dec 26, 2023 at 13:30
  • I'm using GNOME 42.9 and X11 as windowing system on Ubuntu 22.04 too. echo $XDG_CURRENT_DESKTOP returns GNOME.
    – zzzhhh
    Dec 26, 2023 at 14:12
  • but not Ubuntu:GNOME ? Which distro are you using?
    – graham
    Dec 26, 2023 at 15:07
  • I can choose what desktop to use at login. Whatever I choose, GNOME or Ubuntu, the desktop is always dock, not dash. This is a screenshot where echo $XDG_CURRENT_DESKTOP returns ubuntu:GNOME: ibb.co/XympFnR. The distro is Ubuntu 22.04.3 LTS server installed from ubuntu-22.04.3-live-server-amd64.iso downloaded from Canonical official website. Now I start to suspect Canonical forces Ubuntu 22.04 users to use dock desktop no matter what.
    – zzzhhh
    Dec 26, 2023 at 15:56
1

Please go to extensions and find "dash-to-dock". And then "Settings" Make your choice for dock position.

If you don't have this extension for install please try this command: sudo apt install gnome-shell-extension-dashtodock

Source: https://extensions.gnome.org/extension/307/dash-to-dock/

You can select themes and different customizations. For this run "gnome-tweaks" command on terminal and then select appearence tab.

If you don't have already: Please install gnome-tweaks with

sudo apt install gnome-tweaks command

Good luck

5
  • 1. my extensions doesn't have dash-to-dock. Of course I can install it, but 2. What I want is dock-to-dash, so the "dash-to-dock" extension doesn't help, for I'm in dock already. 3. I cannot find any function in Appearance tab of "gnome-tweaks" that can convert dock to dash. Nowhere else in gnome-tweaks has this function either.
    – zzzhhh
    Dec 26, 2023 at 12:27
  • "I cannot find any function in Appearance tab of "gnome-tweaks" that can convert dock to dash" - correct, that option odes not exist in Tweaks v42 beta GTK 3.24.33
    – graham
    Dec 26, 2023 at 13:28
  • @Ertan Mantas: To repeat: 2. What I want is dock-to-dash, so the "dash-to-dock" extension doesn't help, for I'm in dock already.
    – zzzhhh
    Dec 26, 2023 at 13:42
  • @graham: So you mean newer version of Tweaks has dock-to-dash option? What version?
    – zzzhhh
    Dec 26, 2023 at 13:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .