2

I created a hot spot via network > wireless > use as hotspot.

Other laptops successfully detected the hot-spot,could connect and use it without any problem.

But no android phone could detect it.! I tried with many android phones but none could.(I found out that even an ad-hoc created in windows is not detected by any phone)

So is there anything wrong i am doing(rather i am not doing anything actually other than clicking on the "use as hotspot" button..but still..)? or is that the network cannot be shared with phones? and if not,how can i share it with phones?

  • A downvote? what for? – Nirmik Jun 12 '12 at 12:13
  • 1
    People probably downvoted because they didn't realize the question is about Ubuntu (which it was, since you created the ad-hoc network in Ubuntu and for all you knew there was an Ubuntu-specific fix). There is no reason for someone to have assumed you weren't using Ubuntu or that your question is not Ubuntu-related ...but people make mistakes. In the long run, upvotes will cancel out downvotes (including mistaken or random downvotes). – Eliah Kagan Jun 12 '12 at 17:32
  • @EliahKagan..Thanx a lot! m editing the title i guess to add IN UBUNTU ;) – Nirmik Jun 12 '12 at 17:35
4

I think Android doesn't support ad-hoc networking.

  • Then should i select "infrastructure" instead of "adhoc" – Nirmik Jun 12 '12 at 9:29
  • Give it a try. It will work if your Wireless Adapter supports it. It's safe. (I haven't tried that before, though) – wajed Jun 12 '12 at 9:58
  • That probably won't work. most wifi adapters do not support 'infrastructure' nets being hosted on them... – Thomas Ward Jun 12 '12 at 17:55
2

Android by default doesn't allow you to connect to ad-hoc networks. There are many patches available online that allow you to connect to ad-hoc networks, but you need to be root to apply the patch.

-1

Please follow this tutorial to make the adhoc connection in ubuntu , act like a wifi hotspot .

We are using hostapd for creating the hotspot . to Install , type : sudo apt-get install hostapd

Copy the below config to a hostapd.conf in ur home folder .

replace the password with yours.

interface=wlan0 driver=nl80211 ssid=MyAP hw_mode=g channel=11 wpa=1 wpa_passphrase=MyPasswordHere wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP CCMP wpa_ptk_rekey=600

Then , simply create an adhoc connection and issue sudo hostapd hostapd.conf in the terminal .

For detailed explanation :

http://shaer.me/blog/2012/08/how-to-enable-ad-hoc-connection-on-your-android/

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.