2

I have been using the NetworkManager with my Unis' VPN for years, and it used to work. Now they introduced multi-factor authentification using TOTP and I can't connect anymore.

I tried to setup the VPN, using Cisco AnyConnect, entered the correct gateway and selected the token mode 'TOTP-manually entered'. When I try to connect, I first have to enter my usual user name and password, which works as before without the MFA. In the next step I get asked for the one time password, but there is no way to enter it... There just is no textbox for it. Is this just a bug in the network manager or a do I need to change some settings? How do I get this running?

I would like to keep using NetworkManager! I am using Ubuntu 22.04.3 LTS.

Thanks to anyone who can help!

2

1 Answer 1

0

It seems like this is a bug: Keep an eye on the relevant issue thread NM doesn't ask for TOTP with openconnect upstream, as well as the linked merge request libnmc: support 2FA authentication from VPN plugins.

In the meantime, since this is would be a bug in NetworkManager only (and not in the underlying openconnect), you should be able to use openconnect directly to establish a connection:

sudo openconnect --protocol=anyconnect --useragent=AnyConnect your-vpn-server.address.com
3
  • Yes, that looks like my bug. You are right, I can connect in the terminal, thanks for this advice!
    – Mars
    Feb 1 at 16:27
  • sadly not working for me (using Debian 12). the terminal asks for username/pwd. Then terminates the session with You have no dial-in permission and reloops to asking user/pwd.
    – Polymerase
    Feb 5 at 13:25
  • I had installed the Cisco Secure Client as recommended by my Uni before seeing this answer, which also works for me. Not really what I wanted, and I am very happy that I have an alternative now, but it was better than not having access to my stuff. Maybe something similar would work for you too, as a last resort? However, I think your problem might also be different than mine, it somehow sounds as if there is something wrong with your networks settings ((?) I have not much knowledge about that) for your user? Do you have some IT service that you can ask about that?
    – Mars
    Feb 6 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .